• 【BZOJ2134】单选错位 期望


    【BZOJ2134】单选错位

    Description

    Input

    n很大,为了避免读入耗时太多,输入文件只有5个整数参数n, A, B, C, a1,由上交的程序产生数列a。下面给出pascal/C/C++的读入语句和产生序列的语句(默认从标准输入读入): // for pascal readln(n,A,B,C,q[1]); for i:=2 to n do q[i] := (int64(q[i-1]) * A + B) mod 100000001; for i:=1 to n do q[i] := q[i] mod C + 1; // for C/C++ scanf("%d%d%d%d%d",&n,&A,&B,&C,a+1); for (int i=2;i<=n;i++) a[i] = ((long long)a[i-1] * A + B) % 100000001; for (int i=1;i<=n;i++) a[i] = a[i] % C + 1; 选手可以通过以上的程序语句得到n和数列a(a的元素类型是32位整数),n和a的含义见题目描述。

    Output

    输出一个实数,表示gx期望做对的题目个数,保留三位小数。

    Sample Input

    3 2 0 4 1

    Sample Output

    1.167
    【样例说明】
    a[] = {2,3,1}
    正确答案 gx的答案 做对题目 出现概率
    {1,1,1} {1,1,1} 3 1/6
    {1,2,1} {1,1,2} 1 1/6
    {1,3,1} {1,1,3} 1 1/6
    {2,1,1} {1,2,1} 1 1/6
    {2,2,1} {1,2,2} 1 1/6
    {2,3,1} {1,2,3} 0 1/6
    共有6种情况,每种情况出现的概率是1/6,gx期望做对(3+1+1+1+1+0)/6 = 7/6题。(相比之下,lc随机就能期望做对11/6题)
    【数据范围】
    对于100%的数据 2≤n≤10000000, 0≤A,B,C,a1≤100000000

    题解:由于期望永远可加,所以我们只需要讨论每一道题能够答对的概率。简单推一推即可发现,答案与原题做没做对一点关系也没有,第i道题作对的概率为1/max(a[i],a[i+1])。

    #include <cstdio>
    #include <iostream>
    #include <cstring>
    using namespace std;
    int n,A,B,C;
    int a[10000010];
    double ans;
    int main()
    {
    	scanf("%d%d%d%d%d",&n,&A,&B,&C,a+1); for (int i=2;i<=n;i++) a[i] = ((long long)a[i-1] * A + B) % 100000001; for (int i=1;i<=n;i++) a[i] = a[i] % C + 1;
    	int i;
    	for(i=1;i<=n;i++)	ans+=1.0/max(a[i],a[i%n+1]);
    	printf("%.3lf",ans);
    	return 0;
    }
  • 相关阅读:
    idea.vmoption文件修改之后,Idea无法打开的问题
    py学习:namedtuple 具名元组
    py学习:可变对象作为函数参数默认值
    图解Python变量与赋值(转)
    github 提交的认证方式
    让 IDEA 忽略某个文件夹的方式
    在 Windows 上开启 telnet 功能
    Java原生日志 Java.util.logging
    转:Python简史
    Maven无法下载fastdfs-client-java依赖,Dependency 'org.csource:fastdfs-client-java:1.27-SNAPSHOT' not found.
  • 原文地址:https://www.cnblogs.com/CQzhangyu/p/7391312.html
Copyright © 2020-2023  润新知