• 【BZOJ1688】[Usaco2005 Open]Disease Manangement 疾病管理 状压DP


    【BZOJ1688】[Usaco2005 Open]Disease Manangement 疾病管理

    Description

    Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible. If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the milk.

    Input

    * Line 1: Three space-separated integers: N, D, and K * Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first integer, d_i, is the count of cow i's diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0. 有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

    Output

    * Line 1: M, the maximum number of cows which can be milked.

    Sample Input

    6 3 2
    0---------第一头牛患0种病
    1 1------第二头牛患一种病,为第一种病.
    1 2
    1 3
    2 2 1
    2 2 1

    Sample Output

    5

    OUTPUT DETAILS:
    If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two
    diseases (#1 and #2), which is no greater than K (2).
    题解:状压DP,刷水有益健康。
    #include <cstdio>
    #include <iostream>
    using namespace std;
    int n,d,k,tot,ans;
    int f[1<<15],s[1<<15],v[1<<15];
    int main()
    {
        scanf("%d%d%d",&n,&d,&k);
        int i,j,a,b,t;
        for(i=1;i<1<<d;i++)
        {
            s[i]=s[i-(i&-i)]+1;
            if(s[i]<=k)    v[++tot]=i;
        }
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a);
            t=0;
            for(j=1;j<=a;j++)
            {
                scanf("%d",&b);
                t+=1<<b-1;
            }
            for(j=1;j<=tot;j++)
                if((v[j]&t)==t)
                    f[j]++,ans=max(ans,f[j]);
        }
        printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    java 集合类说明与区别
    JAVA集合LIST MAP SET详解
    ThinkPHP文件上传
    ThinkPHP表单操作(未加验证)
    常用的正则表达式大全
    ThinkPHP模板替换
    ThinkPHP包含文件
    example_UEditor富文本编辑器
    ThinkPHP快捷方法汇总(随时添加)
    页面编码统一(转载)
  • 原文地址:https://www.cnblogs.com/CQzhangyu/p/6208964.html
Copyright © 2020-2023  润新知