• POJ 3122 Pie


    纠结了好一阵子:
    2分(向大的方向)+精度
     
    Pie
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 7983Accepted: 2928Special Judge

    Description

    POJ 3122 Pie - qhn999 - 码代码的猿猿My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

    My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

    What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

    Input

    One line with a positive integer: the number of test cases. Then for each test case:
    • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
    • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

    Output

    For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10?3.

    Sample Input

    33 34 3 31 24510 51 4 2 3 4 5 6 5 4 2

    Sample Output

    25.13273.141650.2655

    Source


    #include <iostream>
    #include <iomanip>
    #include <cmath>

    #define pi acos(-1.0)
    #define eps  1e-6

    using namespace std;

    double pei[10010];

    int main()
    {
    int k,r,n,f;
    cin>>k;
    for(int i=0;i<k;i++)
    {
    double MAX=-1,MIN=0,MID=0;
    cin>>n>>f;
    for(int j=0;j<n;j++)
    {
    cin>>r;
    pei[j]=pi*r*r;
    if(pei[j]-MAX>eps)
    MAX=pei[j];
    }


    while(MAX-MIN>eps)
    {
    int sum=0;
    MID=(MAX+MIN)/2.;

    //cout<<MIN<<"  "<<MID<<"  "<<MAX<<" sum: ";

    for(int j=0;j<n;j++)
    {
    sum+=(int)(pei[j]/MID);
    }
    //cout<<sum<<endl;
    if(sum<f+1)
    {
    MAX=MID;
    }
    else if(sum>=f+1)
    {
    MIN=MID;
    }
    }
            cout<<fixed<<setprecision(4)<<MID<<endl;

    }


    return 0;
    }


  • 相关阅读:
    二叉树--转换二叉树(leetcode 108,leetcode 109)
    二叉树--层序遍历(leetcode 102
    二叉树--对称二叉树(leetcode 101
    数据库事务隔离
    二叉树--后序遍历的递归和非递归(leetcode 145
    二叉树--中序遍历的递归和非递归(leetcode 94
    二叉树--先序遍历的递归和非递归(leetcode 144
    链表--排序链表(leetcode 148
    接口的调用
    查锁表以及杀进程
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351090.html
Copyright © 2020-2023  润新知