• POJ 2182 Lost Cows


    Lost Cows
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 8054Accepted: 5130

    Description

    N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

    Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

    Given this data, tell FJ the exact ordering of the cows. 

    Input

    * Line 1: A single integer, N 

    * Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

    Output

    * Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

    Sample Input

    51210

    Sample Output

    24531

    Source

    #include <cstring>

    using namespace std;

    int n;
    int a[8888];
    int b[8888];
    int c[8888];

    int main()
    {
        int n;

        memset(c,-1,sizeof(c));
        cin>>n;
        for(int i=0;i<n-1;i++)
            cin>>a;

        for(int i=0;i<n;i++)
        {
            c=i+1;
        }
        int cur=n-1;
        for(int i=n-2;i>=0;i--)
        {
            int tot=a;
            for(int j=0;j<n;j++)
            {
                if(tot==0&&c[j]!=-1)
                {
                    b[cur]=c[j];
                    c[j]=-1;
                    cur--;
                    break;
                }
                else if(c[j]!=-1)
                {
                    tot--;
                }
            }
        }
        for(int j=0;j<n;j++)
        {
            if(c[j]!=-1) { b[0]=c[j]; break; }
        }

        for(int i=0;i<n;i++)
            cout<<b<<endl;

        return 0;
    }

  • 相关阅读:
    [ SharePoint ADFS 开发部署系列 (一)]
    [ Office 365 开发系列 ] Graph Service
    [ Office 365 开发系列 ] 身份认证
    [ Office 365 开发系列 ] 开发模式分析
    [ Office 365 开发系列 ] 前言
    Debian安装Chrome
    SharePoint 常用操作杂谈
    SharePoint Managed Metadata 使用总结
    SharePoint PerformancePoint开发实例
    node使用mysql报错
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351067.html
Copyright © 2020-2023  润新知