• HDOJ 1025 Constructing Roads In JGShining's Kingdom


    坑爹题:
    先用n^2的LIS写,TLE了,然后改成nlogn的LIS又WA了。原来是 road  和  roads 不一样。。。。。。HDOJ 1025 Constructing Roads In JGShining39;s Kingdom - qhn999 - 码代码的猿猿 

    The poor cities strongly BS each other   。。。。 鄙视??HDOJ 1025 Constructing Roads In JGShining39;s Kingdom - qhn999 - 码代码的猿猿 

    Constructing Roads In JGShining's Kingdom

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 11392    Accepted Submission(s): 3263


    Problem Description
    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

    For example, the roads in Figure I are forbidden.

    HDOJ 1025 Constructing Roads In JGShining39;s Kingdom - qhn999 - 码代码的猿猿


    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
     

    Input
    Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
     

    Output
    For each test case, output the result in the form of sample. 
    You should tell JGShining what's the maximal number of road(s) can be built. 
     

    Sample Input
    2
    1 2
    2 1
    3
    1 2
    2 3
    3 1
     

    Sample Output
    Case 1:
    My king, at most 1 road can be built.

    Case 2:
    My king, at most 2 roads can be built.
    Hint
    Huge input, scanf is recommended.
     

    Author
    JGShining(极光炫影)
     

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>

    using namespace std;

    struct city
    {
        int p;
        int r;
    }c[505000];


    int cur=0;

    bool cmp(city a,city b)
    {
        return a.p<=b.p;
    }

    int LIS[505000];

    int main()
    {
        int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(c,0,sizeof(c));

        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&c.p,&c.r);
        }

        sort(c,c+n,cmp);

        int cnt=0;
        memset(LIS,-1,sizeof(LIS));

        LIS[0]=c[0].r;
        for(int i=1;i<n;i++)
        {
            if(c.r>LIS[cnt])
            {
                cnt++;
                LIS[cnt]=c.r;
            }
            else
            {
                *lower_bound(LIS,LIS+cnt+1,c.r)=c.r;
            }
        }
    /*
        cout<<">>>>>>>>>>>>>>"<<endl;
        for(int i=0;i<=cnt;i++)
            cout<<LIS<<" ";
        cout<<endl;
    */

        printf("Case %d:\n",++cur);
        if(cnt==0)
        printf("My king, at most %d road can be built.\n\n",cnt+1);
        else
        printf("My king, at most %d roads can be built.\n\n",cnt+1);

    }

        return 0;
    }

  • 相关阅读:
    定时任务cron表达式解析
    dubbo admin的搭建(windows环境)
    搭建一个基于springboot的dubbo demo
    mysql考试成绩排名-关于@rowtotal、@rownum
    理解JMM及volatile关键字
    UnityLearn_Beginner_UnityTips
    UnityLearn_Beginner_UnityBasics
    Unity3D&Photon制作吃鸡游戏(未完)
    UNITY_UGUI
    UNITY_资源路径与加载外部文件
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351040.html
Copyright © 2020-2023  润新知