• HDOJ 1518 Square



    Square

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5443    Accepted Submission(s): 1732


    Problem Description
    Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
     

    Input
    The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
     

    Output
    For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
     

    Sample Input
    3
    4 1 1 1 1
    5 10 20 30 40 50
    8 1 7 2 6 4 4 3 5
     

    Sample Output
    yes
    no
    yes
     

    Source
     

    Recommend
    LL
     


    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>

    using namespace std;

    int sum;
    int n;
    int a[25];
    int vis[25];

    bool dfs(int cur,int time,int k)
    {
        if(time==3)
        {
           return true;
        }
        for(int i=k-1;i>=0;i--)
        {
            if(!vis)
            {
                vis=1;
                if(cur+a==sum)
                {
                    if(dfs(0,time+1,n))
                        return true;
                }
                else if(cur+a<sum)
                {
                    if(dfs(cur+a,time,i)) return true;
                }
                vis=0;
            }
        }
        return false;
    }

    int main()
    {
        int T;
        scanf("%d",&T);
    while(T--)
    {
        memset(vis,0,sizeof(vis));
        sum=0;
        int maxn=-1;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            sum+=a;
            maxn=max(maxn,a);
        }
        if(sum%4!=0||maxn>sum/4)
        {
            puts("no");
            continue;
        }
        sum=sum/4;
        sort(a,a+n);
        if(dfs(0,0,n)) puts("yes");
        else puts("no");
    }
        return 0;
    }

  • 相关阅读:
    Jenkins中Jelly邮件模板的配置
    十天冲刺(10)
    代码大全阅读笔记01
    大二下学期学习进度(十)
    十天冲刺(9)
    十天冲刺(8)
    统计文章中字母、单词出现的频率
    十天冲刺(7)
    十天冲刺(6)
    十天冲刺(5)
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351004.html
Copyright © 2020-2023  润新知