• POJ 2367 Genealogical tree


    换种颜色试试。。。。。
     
    Genealogical tree
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 2149Accepted: 1457Special Judge

    Description

    The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
    And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
    Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

    Input

    The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

    Output

    The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

    Sample Input

    504 5 1 01 05 3 03 0

    Sample Output

    2 4 5 3 1

    Source




    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    bool mp[110][110];
    int in_degree[110];
    int N;

    int main()
    {
        scanf("%d",&N);

        memset(mp,false,sizeof(mp));
        memset(in_degree,0,sizeof(in_degree));

        for(int i=1;i<=N;i++)
        {
            int k;
            while(cin>>k)
            {
                if(k==0) break;
                mp[k]=true;
                in_degree[k]++;
            }
        }

        int ans[110];
        int cnt=0;
        while(cnt<N)
        {
            int i=1;
            for(i=1;i<=N;i++)
            {
                if(in_degree==0)
                    break;
            }
            in_degree--;
            ans[cnt]=i;
            cnt++;

            for(int j=1;j<=N;j++)
            {
                if(mp[j])
                {
                    in_degree[j]--;
                }
            }
        }

        for(int i=0;i<cnt;i++)
        {
            if(i!=0)
              printf(" ");
            printf("%d",ans);
        }

        return 0;
    }

  • 相关阅读:
    WCF 第四章 绑定 在多个绑定上暴露一个服务契约
    WCF 第五章 行为 事务跨操作事务流
    WCF 第五章 导出并发布元数据(服务行为)
    WCF 第五章 行为 通过配置文件暴露一个服务行为
    WCF 第五章 不支持会话的绑定的默认并发和实例
    WCF 第五章 并发和实例(服务行为)
    WCF 第五章 行为 总结
    WCF 第四章 绑定 绑定元素
    WCF 第五章 行为 事务之选择一个事务协议OleTx 或者WSAT
    WCF 第四章 绑定 比较各种绑定的性能和可扩展性
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350973.html
Copyright © 2020-2023  润新知