• HDOJ 1102 Constructing Roads (MST)


    MST的kruska算法。。。。


    Constructing Roads

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10595    Accepted Submission(s): 3940


    Problem Description
    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
     

    Input
    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
     

    Output
    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
     

    Sample Input
    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2
     

    Sample Output
    179
     

    Source
     

    Recommend
    Eddy
     




    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>

    using namespace std;

    const int MAXN=200;

    int father[MAXN],Rank[MAXN],grp[MAXN][MAXN],save[MAXN];

    struct Edge
    {
        int start;
        int end;
        int value;
    }e[8000];

    bool cmp(Edge x,Edge y)
    {
        return x.value<=y.value;
    }

    int find_father(int x)
    {
        int tot=0;
        while(x!=father[x])
        {
            save[tot++]=x;
            x=father[x];
        }

        for(int i=0;i<tot;i++)
        {
            father[save]=x;
        }

        return x;
    }

    int Union_set(int x,int y,int z)
    {
        int Fx=find_father(x);
        int Fy=find_father(y);

        if(Fx==Fy) return 0;
        if(Rank[Fx]<=Rank[Fy])
        {
            father[Fy]=Fx;
            Rank[Fx]++;
        }
        else
        {
            father[Fx]=Fy;
            Rank[Fy]++;
        }

        return z;
    }

    int main()
    {

        int n;
        while(cin>>n)
        {
            int sum=0;
            int k=1;
            int m,p,q;
            memset(Rank,0,sizeof(Rank));

            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    cin>>grp[j];
            cin>>m;

            for(int i=1;i<=m;i++)
                {
                    cin>>p>>q;
                    grp[p][q]=grp[q][p]=0;
                }
            //邻接矩阵转换为边集
            for(int i=1;i<=n;i++)
                for(int j=i;j<=n;j++)
                {
                    e[k].start=i;
                    e[k].end=j;
                    e[k].value=grp[j];
                    k++;
                }
            //按升序排序
            sort(e+1,e+k,cmp);
            //初始每个节点的祖先为自身
            for(int i=1;i<k;i++)
                father=i;
            // 构造最小生成树,并计算最小权值
            for(int i=1;i<k;i++)
            {
               sum+=Union_set(e.start,e.end,e.value);
            }
            cout<<sum<<endl;
        }
        return 0;
    }

  • 相关阅读:
    SpringBoot统一全局响应(5)
    SpringBoot统一异常处理(4)
    Spring Cloud Alibaba-Gateway搭配Nacos实现动态路由(4)
    SpringBoot使用javax.validation进行参数校验(3)
    SpringBoot使用日志(2)
    WPF 之 ObservableCollection 动态数据集合的使用(二)
    WPF 之 INotifyPropertyChanged 接口的使用 (一)
    数据库访问框架 Chloe
    Navicat Premium 的破解安装教程
    C#定位文件位置并修改字节数据
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350960.html
Copyright © 2020-2023  润新知