• POJ 1056 IMMEDIATE DECODABILITY



    字典树。。。。
    IMMEDIATE DECODABILITY
    Time Limit: 1000MSMemory Limit: 10000K
    Total Submissions: 9753Accepted: 4602

    Description

    An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. 

    Examples: Assume an alphabet that has symbols {A, B, C, D} 

    The following code is immediately decodable: 
    A:01 B:10 C:0010 D:0000 

    but this one is not: 
    A:01 B:10 C:010 D:0000 (Note that A is a prefix of C) 

    Input

    Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

    Output

    For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

    Sample Input

    01
    10
    0010
    0000
    9
    01
    10
    010
    0000
    9

    Sample Output

    Set 1 is immediately decodable
    Set 2 is not immediately decodable

    Source



    #include <iostream>
    #include <cstring>
    #include <cstdio>

    using namespace std;

    struct Trie
    {
        int ch[100000][3];
        bool flag[100000];
        int tot,root;
        void TTrie()
        {
            memset(ch[1],0,sizeof(ch[0]));
            root=1;tot=1;
            flag[1]=false;
        }

        int Insert(const char *str)
        {
            int hav=0;
            int* cur=&root;
            for(const char*p=str;*p;p++)
            {
                cur=&ch[*cur][*p-'0'];
                if(flag[*cur]==true)
                {
                 //   cout<<"**: "<<*cur<<endl;
                    hav=1;
                }
                if(*cur==0)
                {
                    tot++;
                    *cur=tot;
                    memset(ch[tot],0,sizeof(ch[tot]));
                    flag[tot]=false;
                }
            }
            flag[*cur]=true;
            return hav;
        }

    };

    int main()
    {
        int cas=1;
        char str[50000];
        int OK=1;
        Trie tree;
        tree.TTrie();
    while(cin>>str)
    {
        if(str[0]=='9')
        {
            if(OK==0)
            {
                printf("Set %d is not immediately decodable ",cas++);
                OK=1;tree.TTrie();
                continue;
            }
            else
            {
                printf("Set %d is immediately decodable ",cas++);
                OK=1;tree.TTrie();
                continue;
            }
        }
        else
        {
            int temp=tree.Insert(str);
            if(temp==1)
            {
                //cout<<str<<endl;
                OK=0;
            }
        }
    }

        return 0;
    }

  • 相关阅读:
    HBase MapReduce 一些 ClassNotFoundException 所缺少的jar包
    Eclipse 连接不上 hadoop 的解决办法
    Log4j 2 配置
    mysql 查询结果显示行号
    js刷新页面方法 -- (转)
    python 错误--UnboundLocalError: local variable '**' referenced before assignment
    Webview 中FaultyInfo代码说明
    HTML中设置超链接字体 & 字体颜色
    apache log 按日期记录 格式 <GOOD>-- (转)
    linux 下 /bin /sbin 的区别 -- (转)
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350949.html
Copyright © 2020-2023  润新知