• ZOJ 3182 Nine Interlinks




    Nine Interlinks

    Time Limit: 1 Second      Memory Limit: 32768 KB

    "What are you doing now?"

    "Playing Nine Interlinks!"

    "What is that?"

    "Oh it is an ancient game played over China. The task is to get the nine rings off the stick according to some rules. Now, I have got them off, would you like to have a try to get them on?"

    Input

    The first line of the input contains an integer T (T <= 30), indicating the number of cases.

    Each case consists of a simple integer n (1 < n < 30), which is the number of the total rings you need to get on the stick.

    At the beginning, all rings are off the stick.

    In each step, you can only get one ring on or off by the following rules:

    1. You can get the first ring on or off freely at each step.

    2. If the ith ring is on the stick, and the 1st, 2nd... (i-1)st rings are off the stick, you can get the (i+1)st ring on or off freely at each step.

    Output

    For each case, print in a single line the minimum number of steps you need to get n rings on the stick.

    Sample Input

    2
    2
    3

    Sample Output

    2
    5

    Hint
    The first sample: 1 on, 2 on.
    The second sample: 1 on, 2 on, 1 off, 3 on, 1 on.




    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    int main()
    {
        int T;int n;
        cin>>T;
        int f[40]={0,1,2,5};
        for(int i=4;i<=30;i++)
            f=f[i-1]+f[i-2]+1+f[i-2];
    while(T--)
    {
        cin>>n;
        cout<<f[n]<<endl;
    }
        return 0;
    }



  • 相关阅读:
    关于ping github.com超时的解决办法
    git使用过程中的若干问题笔记
    PAT甲级1017题解——模拟排序
    第七章4
    第七章3
    第七章2
    第七章1
    第六章4
    第六章3
    第六章2
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350943.html
Copyright © 2020-2023  润新知