• HDOJ 4405 Aeroplane chess (DP)



    Aeroplane chess

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 721    Accepted Submission(s): 507


    Problem Description
    Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

    There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

    Please help Hzz calculate the expected dice throwing times to finish the game.
     

    Input
    There are multiple test cases. 
    Each test case contains several lines.
    The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
    Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
    The input end with N=0, M=0. 
     

    Output
    For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
     

    Sample Input
    2 0
    8 3
    2 4
    4 5
    7 8
    0 0
     

    Sample Output
    1.1667
    2.3441
     

    Source
     

    Recommend
    zhoujiaqi2010
     



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    double dp[100010];
    int turn[100010];

    int main()
    {
        int n,m;
    while(scanf("%d%d",&n,&m)!=EOF&&n)
    {
        int a,b;
        memset(turn,0,sizeof(turn));

        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            turn[a]=b;
        }
        memset(dp,0,sizeof(dp));

        for(int i=n-1;i>=0;i--)
        {
            if(turn)
            {
                dp=dp[turn];
            }
            else
            {
                dp=1;
                for(int j=1;j<=6&&i+j<=n;j++)
                {
                    dp+=dp[i+j]/6.;
                }
            }
        }

        printf("%.4lf ",dp[0]);

    }

        return 0;
    }


  • 相关阅读:
    shell day01总结
    PythonDay02
    Python Day01
    802.11X
    IPsec
    Gre封装
    达梦数据库常见问题-命令行工具-主备集群监视器工具
    达梦数据库常见问题-命令行工具-初始化实例工具
    达梦数据库常见问题-命令行工具-快速装载工具
    达梦数据库常见问题-命令行工具-数据检查工具
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350941.html
Copyright © 2020-2023  润新知