• HDOJ 1754 I Hate It




    线段树单点更新

    I Hate It

    Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 26593    Accepted Submission(s): 10564


    Problem Description
    很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
    这让很多学生很反感。

    不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
     

    Input
    本题目包含多组测试,请处理到文件结束。
    在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
    学生ID编号分别从1编到N。
    第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
    接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
    当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
    当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
     

    Output
    对于每一次询问操作,在一行里面输出最高成绩。
     

    Sample Input
    5 61 2 3 4 5Q 1 5U 3 6Q 3 4Q 4 5U 2 9Q 1 5
     

    Sample Output
    5659
    Hint
    Huge input,the C function scanf() will work better than cin
     

    Author
    linle
     

    Source
     

    Recommend
    lcy
     


    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1

    const int maxn=222222;
    int MAX[maxn<<2];

    void pushUP(int rt)
    {
        MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);
    }

    void build(int l,int r,int rt)
    {
        if(l==r)
        {
            scanf("%d",&MAX[rt]);
            return ;
        }
        int m=(l+r)>>1;
        build(lson);
        build(rson);

        pushUP(rt);
    }

    void update(int p,int sc,int l,int r,int rt)
    {
        if(l==r)
        {
            MAX[rt]=sc;
            return ;
        }

        int m=(r+l)>>1;
        if(p<=m)
            update(p,sc,lson);
        else
            update(p,sc,rson);

        pushUP(rt);
    }

    int query(int L,int R,int l,int r,int rt)
    {
        if(L<=l&&r<=R)
            return MAX[rt];

        int m=(r+l)>>1;
        int ret=0;
        if(L<=m) ret=max(ret,query(L,R,lson));
        if(R>m) ret=max(ret,query(L,R,rson));

        return ret;
    }

    int main()
    {
        int n,m,a,b;
    while(~scanf("%d%d",&n,&m))
    {
        memset(MAX,0,sizeof(MAX));
        build(1,n,1);
        char s[3];
        while(m--)
        {
            scanf("%s%d%d",s,&a,&b);
            if(s[0]=='Q')
                printf("%d ",query(a,b,1,n,1));
            else
                update(a,b,1,n,1);
        }
    }

        return 0;
    }



  • 相关阅读:
    [转] Optimizely:在线网站A/B测试平台
    批处理命令——choice
    批处理命令——%0
    批处理命令——call 和 start
    批处理命令——rem 和 pause
    批处理命令——goto 和 :
    PHPCMS V9 学习总结
    PHPCMS V9 环境搭建
    批处理命令——echo 和 @
    利用Qt Assistant 定制帮助文档
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350937.html
Copyright © 2020-2023  润新知