• ZOJ 3471 Most Powerful


     状压DP。。。

    Most Powerful

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

    You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

    Input

    There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

    The last case is followed by a 0 in one line.

    There will be no more than 500 cases including no more than 50 large cases that N is 10.

    Output

    Output the maximal power these N atoms can produce in a line for each case.

    Sample Input

    2
    0 4
    1 0
    3
    0 20 1
    12 0 1
    1 10 0
    0

    Sample Output

    4
    22


    Author: GAO, Yuan
    Contest: ZOJ Monthly, February 2011

    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int mp[11][11];
    int dp[2000];

    int main()
    {
        int n;
    while(cin>>n&&n)
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
               cin>>mp[j];
        memset(dp,0,sizeof(dp));

        int m=(1<<n)-1;

        for(int i=0;i<=m;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(!(i&(1<<j)))
                for(int k=0;k<n;k++)
                {
                    if(!(i&(1<<k))&&k!=j)
                    {
                        if(dp[i|(1<<k)]<dp+mp[j][k])
                            dp[i|(1<<k)]=dp+mp[j][k];
                    }
                }
            }
        }

        int ans=-0x3f3f3f3f;
        for(int i=0;i<=m;i++)
            ans=max(ans,dp);

        cout<<ans<<endl;
    }
        return 0;
    }


  • 相关阅读:
    关于cookie的一点知识
    一点简单的关于ASP.NET下载
    一个小小小问题
    复习linq
    拾遗一些关于存储过程
    一般处理程序(下)
    复习一下递归
    复习JS和jQuery
    一点关于Ajax和一个等待图标的显示
    C#开发BIMFACE系列14 服务端API之批量获取转换状态详情
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350919.html
Copyright © 2020-2023  润新知