• HDOJ 1907 John



    对于任意一个 Anti-SG 游戏,如果我们规定当局面中所有的单一游戏的 SG 值为 0 时,游戏结束,则先手必胜当且仅当: 
    (1)游戏的 SG 函数不为 0 且游戏中某个单一游戏的 SG 函数大于 1;
    (2)游戏的 SG 函数
    为 0 且游戏中没有单一游戏的 SG 函数大于 1。

    John

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
    Total Submission(s): 2233    Accepted Submission(s): 1200


    Problem Description
    Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

    Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

     

    Input
    The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

    Constraints:
    1 <= T <= 474,
    1 <= N <= 47,
    1 <= Ai <= 4747

     

    Output
    Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

     

    Sample Input
    2
    3
    3 5 1
    1
    1
     

    Sample Output
    John
    Brother
     

    Source
     

    Recommend
    lcy
     
     


    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            int n,XOR=0,a,k=0;
            scanf("%d",&n);
            while(n--)
            {
                scanf("%d",&a);
                XOR^=a;
                if(a>1) k++;
            }
            if((XOR==0&&k==0)||(XOR!=0&&k!=0))
                puts("John");
            else
                puts("Brother");
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    mac下的一个类似“_kbhit()”实现
    mac使用备注
    open()打开文件失败对应的各种错误码
    xcode显示行号show gutter
    下载google code中源码的几个工具
    HTML5迷你游戏作验证码
    Linux+eclipse+gdb调试postgresql源码
    S-Nim
    【求助】从大表中删除小表中存在的记录问题
    Binary Tree Zigzag Level Order Traversal (LeetCode) 层序遍历二叉树
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350860.html
Copyright © 2020-2023  润新知