• POJ 1276 Cash Machine




    Cash Machine
    Time Limit: 1000MSMemory Limit: 10000K
    Total Submissions: 24213Accepted: 8476

    Description

    A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

    N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

    means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

    Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

    Notes: 
    @ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

    Input

    The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

    cash N n1 D1 n2 D2 ... nN DN 

    where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

    Output

    For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

    Sample Input

    735 3  4 125  6 5  3 350
    633 4  500 30  6 100  1 5  0 1
    735 0
    0 3  10 100  10 50  10 10

    Sample Output

    735
    630
    0
    0

    Hint

    The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

    In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

    In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

    Source

    Southeastern Europe 2002 

    都没用多重背包,随便写了个DP+二进制优化。。。。
     
     
    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    bool money[110000];
    int num[1100],coin[1100];
    int cash,n;

    int main()
    {
        while(scanf("%d",&cash)!=EOF)
        {
            scanf("%d",&n);
            memset(money,false,sizeof(money));
            money[0]=true;
            for(int i=0;i<n;i++)
            {
                scanf("%d%d",&num,&coin);
                if(money[cash]) continue;
                for(int j=1;j<=num;j<<=1)
                {
                    int val=j*coin;
                    for(int k=cash;k>=0;k--)
                    {
                        if(money[k]) if(k+val<=cash) money[k+val]=true;
                    }
                    num-=j;
                }
                if(num)
                {
                    int val=num*coin;
                    for(int k=cash;k>=0;k--)
                    {
                        if(money[k]) if(k+val<=cash) money[k+val]=true;
                    }
                }
            }
            int ans=0;
            for(int i=cash;i>=0;i--)
            {
                if(money)
                {
                    ans=i; break;
                }
            }
            printf("%d ",ans);
        }

        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    ArcGIS engine中Display类库 (局部刷新)
    ArcGIS 空间查询一例
    反射方法获取事件的委托链上的函数
    [转] 基于C#的波形显示控件的实现
    C# 对Excel操作时,单元格值的读取
    44.Node.js Express 框架--web框架
    43.安装npm及cnpm(Windows)
    42.cnpm不是内部命令的解决方案:配置环境变量
    41.Node.js使用cnpm
    40.Node.js Web 模块
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350856.html
Copyright © 2020-2023  润新知