• POJ 2029 Get Many Persimmon Trees




    Get Many Persimmon Trees
    Time Limit: 1000MSMemory Limit: 30000K
    Total Submissions: 3243Accepted: 2113

    Description

    Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of Aizu, had decided to grant him a rectangular estate within a large field in the Aizu Basin. Although the size (width and height) of the estate was strictly specified by the lord, he was allowed to choose any location for the estate in the field. Inside the field which had also a rectangular shape, many Japanese persimmon trees, whose fruit was one of the famous products of the Aizu region known as 'Mishirazu Persimmon', were planted. Since persimmon was Hayashi's favorite fruit, he wanted to have as many persimmon trees as possible in the estate given by the lord. 
    For example, in Figure 1, the entire field is a rectangular grid whose width and height are 10 and 8 respectively. Each asterisk (*) represents a place of a persimmon tree. If the specified width and height of the estate are 4 and 3 respectively, the area surrounded by the solid line contains the most persimmon trees. Similarly, if the estate's width is 6 and its height is 4, the area surrounded by the dashed line has the most, and if the estate's width and height are 3 and 4 respectively, the area surrounded by the dotted line contains the most persimmon trees. Note that the width and height cannot be swapped; the sizes 4 by 3 and 3 by 4 are different, as shown in Figure 1. 
    POJ 2029 Get Many Persimmon Trees - qhn999 - 码代码的猿猿 
    Figure 1: Examples of Rectangular Estates

    Your task is to find the estate of a given size (width and height) that contains the largest number of persimmon trees.

    Input

    The input consists of multiple data sets. Each data set is given in the following format. 


    W H 
    x1 y1 
    x2 y2 
    ... 
    xN yN 
    S T 

    N is the number of persimmon trees, which is a positive integer less than 500. W and H are the width and the height of the entire field respectively. You can assume that both W and H are positive integers whose values are less than 100. For each i (1 <= i <= N), xi and yi are coordinates of the i-th persimmon tree in the grid. Note that the origin of each coordinate is 1. You can assume that 1 <= xi <= W and 1 <= yi <= H, and no two trees have the same positions. But you should not assume that the persimmon trees are sorted in some order according to their positions. Lastly, S and T are positive integers of the width and height respectively of the estate given by the lord. You can also assume that 1 <= S <= W and 1 <= T <= H. 

    The end of the input is indicated by a line that solely contains a zero. 

    Output

    For each data set, you are requested to print one line containing the maximum possible number of persimmon trees that can be included in an estate of the given size.

    Sample Input

    16
    10 8
    2 2
    2 5
    2 7
    3 3
    3 8
    4 2
    4 5
    4 8
    6 4
    6 7
    7 5
    7 8
    8 1
    8 4
    9 6
    10 3
    4 3
    8
    6 4
    1 2
    2 1
    2 4
    3 4
    4 2
    5 3
    6 1
    6 2
    3 2
    0

    Sample Output

    4
    3

    Source

    Japan 2003 Domestic 

    二维树状数组。。。。树状数组扩展到二维果然很容易啊。。。



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int tree[200][200];
    int N,M,num;
    inline int lowbit(int x) {return x&(-x);}
    void add(int addx,int addy,int addv)
    {
        int temp=addy;
        while(addx<=N)
        {
            addy=temp;
            while(addy<=M)
            {
                tree[addx][addy]+=addv;
                addy+=lowbit(addy);
            }
            addx+=lowbit(addx);
        }
    }
    int sum(int x,int y)
    {
        int ans=0,temp=y;
        while(x>0)
        {
            y=temp;
            while(y>0)
            {
                ans+=tree[x][y];
                y-=lowbit(y);
            }
            x-=lowbit(x);
        }
        return ans;
    }
    int Getsum(int x1,int y1,int x2,int y2)
    {
        return sum(x2,y2)-sum(x2,y1-1)-sum(x1-1,y2)+sum(x1-1,y1-1);
    }

    int main()
    {
        while(scanf("%d",&num)!=EOF&&num)
        {
            memset(tree,0,sizeof(tree));
            scanf("%d%d",&N,&M);
            while(num--)
            {
                int a,b;
                scanf("%d%d",&a,&b);
                add(a,b,1);
            }
            int r,c,ans=0;
            scanf("%d%d",&r,&c);
            for(int i=1;i+r-1<=N;i++)
            {
                for(int j=1;j+c-1<=M;j++)
                {
                    ans=max(Getsum(i,j,i+r-1,j+c-1),ans);
                }
            }
            printf("%d ",ans);
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    C++ 并发编程 01 线程api
    C# CS1591 缺少对公共可见类型或成员的 XML 注释 问题解决
    Web Api HelpPage
    C++11新特性介绍 02
    C++11新特性介绍 01
    Autofac框架详解
    Linux gdb调试器用法全面解析
    BCM_SDK命令
    VLAN
    java_Observer Design Pattern
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350843.html
Copyright © 2020-2023  润新知