3-4 计算长方形的周长和面积
Problem Description
Input
输入两个实数,中间用一个空格间隔;代表长方形的长和宽
Output
共有6行 ;
分别输出r1的长和宽; r1的周长; r1的面积;r2的长和宽; r2的周长; r2的面积;注意单词与单词之间用一个空格间隔
Example Input
56 32
Example Output
the length and width of r1 is:56,32 the perimeter of r1 is:176 the area of r1 is:1792 the length and width of r2 is:56,32 the perimeter of r2 is:176 the area of r2 is:1792
Hint
输入 -7.0 -8.0
输出
the length and width of r1 is:0,0
the perimeter of r1 is:0
the area of r1 is:0
the length and width of r2 is:0,0
the perimeter of r2 is:0
the area of r2 is:0
#include <iostream>
using namespace std;
class Rect
{
private:
double length;
double width;
public:
Rect(double x=0,double y =0)
{
length = x;
width = y;
}
Rect(const Rect &b)
{
length = b.length;
width = b.width;
}
const void display()
{
cout << "the length and width of r1 is:" << length << ","<< width << endl;
cout << "the perimeter of r1 is:" << (length + width) * 2<<endl;
cout << "the area of r1 is:" << length * width << endl;
}
void display1()
{
cout << "the length and width of r2 is:" << length << ',' << width<< endl;
cout << "the perimeter of r2 is:" << (length + width) * 2 << endl;
cout << "the area of r2 is:" << length * width << endl;
}
};
int main()
{
double x,y;
cin>>x>>y;
if(x<0||y<0)
{
x=0;
y=0;
}
Rect r1(x,y);
Rect r2 = r1;
r1.display();
r2.display1();
return 0;
}