• 数据结构实验之链表七:单链表中重复元素的删除


    数据结构实验之链表七:单链表中重复元素的删除

    Time Limit: 1000MS Memory Limit: 65536KB

    Problem Description

    按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

    Input

    第一行输入元素个数n; 
    第二行输入n个整数。

    Output

    第一行输出初始链表元素个数; 
    第二行输出按照逆位序所建立的初始链表;
    第三行输出删除重复元素后的单链表元素个数;
    第四行输出删除重复元素后的单链表。

    Example Input

    10
    21 30 14 55 32 63 11 30 55 30

    Example Output

    10
    30 55 30 11 63 32 55 14 30 21
    7
    30 55 11 63 32 14 21

    #include<stdio.h>
    #include<malloc.h>
    struct LinkList{
        int data;
        struct LinkList *next;
    };
    LinkList * CreateList(LinkList *head,int n){
        LinkList *r;
        head->next=NULL;
        for(int i=0;i<n;i++){
            r=(LinkList *)malloc(sizeof(LinkList));
            scanf("%d",&r->data);
            r->next=head->next;
            head->next=r;
        }
        return head;
    }
    LinkList *DeleList(LinkList *&head,int &n){
        LinkList *p,*q,*temp1,*temp2;
        p=head->next;
        q=p->next;
        while(p->next!=NULL){
            temp1=p;
            while(q!=NULL){
                if(p->data==q->data){
                    temp2=q;
                    q=q->next;
                    temp1->next=q;
                    free(temp2);
                    n--;
                }else{
                    q=q->next;
                    temp1=temp1->next;
                }
            }
            p=p->next;
            q=p->next;
        }
        printf("%d\n",n);
        return head;
    }
    void DispList(LinkList *head){
        LinkList *p=head->next;
        while(p->next!=NULL){
            printf("%d ",p->data);
            p=p->next;
        }
        printf("%d\n",p->data);
    }
    int main(){
        int n;
        scanf("%d",&n);
        LinkList *head;
        head=(LinkList *)malloc(sizeof(LinkList));
        CreateList(head,n);
        printf("%d\n",n);
        DispList(head);
        DeleList(head,n);
        DispList(head);
        return 0;
    }
    


  • 相关阅读:
    [WPF]Win10便签软件
    [WPF]使用Fody提高效率
    [WPF]限制程序单例运行
    [WPF]创建系统栏小图标
    Run Performance Testing Which Was Distributed To Multiple Test Agents
    FxZ,C#开发职位面试测试题(30分钟内必须完成)
    BYS推荐MS前端PhoneCall面试问题整理-2
    BYS推荐MS前端PhoneCall面试问题整理-1
    LxNx前端F2F面试问题整理
    复杂DIV交错布局
  • 原文地址:https://www.cnblogs.com/CCCrunner/p/6444600.html
Copyright © 2020-2023  润新知