• 【POJ】[1852]Ants


    Ants
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 13088   Accepted: 5735

    Description

    An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

    Input

    The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

    Output

    For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

    Sample Input

    2
    10 3
    2 6 7
    214 7
    11 12 7 13 176 23 191
    

    Sample Output

    4 8
    38 207


    智商题

    n只蚂蚁以每秒1cm的速度在长为Lcm的竿子上爬行。当蚂蚁爬到竿子的端点时就会掉落。由于竿子太细,两只蚂蚁相遇时,它们不能交错通过,只能各自反向爬回去。对于每只蚂蚁,我们知道它距离竿子左端的距离xi,但不知道它当前的朝向。请计算所有蚂蚁落下竿子所需的最短时间和最长时间。

    似乎对照书打一遍毫无意义啊……-.-

    反正是统计 就当做休息一下啦


    作为《挑战程序设计竞赛》中第一道比较正规的题

    刚开始想的时候对这本书的难度惊呆了-_-

    感叹智商不够

    然后这个就是


    关键就是想到蚂蚁的运动都可以理解为单独运动的

    所以求时间最短时只需要找

    离左端点或右两端点最远的那个蚂蚁(最靠近中间朝向更近的边)

    (果然一个木桶能装多少水取决于最短的那个木板嘛)

    求时间最长时只需要找

    离左端点或右两端点最远的那个蚂蚁(最靠近端点朝向更远的边)

    所以代码就很好写了


    #include<cstdio>
    #include<algorithm>
    using namespace std;
    int a[1000200];
    int main() {
    	int T,L,n,Tmin,Tmax;
    	scanf("%d",&T);
    	while(T--) {
    		scanf("%d %d",&L,&n);
    		for(int i=0; i<n; i++)
    			scanf("%d",&a[i]);
    		Tmin=Tmax=0;
    		for(int i=0; i<n; i++)
    			Tmin=max(Tmin,min(a[i],L-a[i]));
    		for(int i=0; i<n; i++)
    			Tmax=max(Tmax,max(a[i],L-a[i]));
    		printf("%d %d\n",Tmin,Tmax);
    	}
    	return 0;
    }

    果然考验智商……

    又回忆一遍……发现还是有点脑抽……

    -.-


    用了C++的代码方式

    也算先体验一把~


    题目地址:【POJ】[1852]Ants

  • 相关阅读:
    【超详细教程】使用Windows Live Writer 2012和Office Word 2013 发布文章到博客园全面总结
    Jquery+asp.net后台数据传到前台js进行解析的方法
    OWASP Top 10 – 2013, 最新十大安全隐患(ASP.NET解决方法)
    Owasp Top 10 Security Risks for 2014
    js中cookie的使用详细分析
    Cookie/Session机制详解
    ASP.NET Web API 简介
    未找到具有固定名称“System.Data.SQLite”的 ADO.NET 提供程序的实体框架提供程序
    网页被Chrome识别成英语,区域,语言,网站
    16进制字符串转换为byte数组
  • 原文地址:https://www.cnblogs.com/BoilTask/p/12569932.html
Copyright © 2020-2023  润新知