• PAT 1047 Student List for Course[一般]


    1047 Student List for Course (25 分)

    Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 numbers: N (40,000), the total number of students, and K (2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

    Output Specification:

    For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

    Sample Input:

    10 5
    ZOE1 2 4 5
    ANN0 3 5 2 1
    BOB5 5 3 4 2 1 5
    JOE4 1 2
    JAY9 4 1 2 5 4
    FRA8 3 4 2 5
    DON2 2 4 5
    AMY7 1 5
    KAT3 3 5 4 2
    LOR6 4 2 4 1 5
    

    Sample Output:

    1 4
    ANN0
    BOB5
    JAY9
    LOR6
    2 7
    ANN0
    BOB5
    FRA8
    JAY9
    JOE4
    KAT3
    LOR6
    3 1
    BOB5
    4 7
    BOB5
    DON2
    FRA8
    JAY9
    KAT3
    LOR6
    ZOE1
    5 9
    AMY7
    ANN0
    BOB5
    DON2
    FRA8
    JAY9
    KAT3
    LOR6
    ZOE1

     题目大意:给出学生总数和课程总数,输入是学生姓名+报名课程编号(从1开始);要求输出课程编号,课程报名总人数和学生姓名。

    //感觉不难,在牛客网上通过了,但是在PAT上测试点1没通过,得了22分,以下:

    #include <iostream>
    #include <map>
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main() {
        int n,m,k;
        cin>>n>>m;
        map<int,vector<string>> mp;
        string name;
        for(int i=0;i<n;i++){
            cin>>name>>k;
            int temp;
            for(int j=0;j<k;j++){
                cin>>temp;
                mp[temp].push_back(name);//可以直接这样放进去的。
            }
        }
        for(auto it=mp.begin();it!=mp.end();it++){
            vector<string> name=it->second;
            cout<<it->first<<" "<<name.size()<<"
    ";
            sort(name.begin(),name.end());
            for(int i=0;i<name.size();i++){
                cout<<name[i]<<'
    ';
            }
        }
        return 0;
    }
    View Code

    //真的不知道是哪里出错了,就先这样吧,不是超时的问题,搜索中发现,以前的运行时间限制分别是200s,400s,现在已经到了1s,所以使用String也是没问题的。

    //知道了,是对于没人选的课,应该输出课程编号和0,但是我什么都没输出:

    因为我是用map做的啊,它根本映射不到,所以所以这种做法是错误的,牛客网上的用也太水了吧。

    #include <iostream>
    #include <map>
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main() {
        int n,m,k;
        cin>>n>>m;
        map<int,vector<string>> mp;
        string name;
        for(int i=0;i<n;i++){
            cin>>name>>k;
            int temp;
            for(int j=0;j<k;j++){
                cin>>temp;
                mp[temp].push_back(name);//可以直接这样放进去的。
            }
        }
        //来个检测
        for(int i=1;i<=m;i++){
            if(mp.count(i)==0){
                vector<string> vt;
                mp[i]=vt;//让它等于一个空向量
            }
        }
    
        for(auto it=mp.begin();it!=mp.end();it++){
            vector<string> name=it->second;
            cout<<it->first<<" "<<name.size()<<"
    ";
            sort(name.begin(),name.end());
            for(int i=0;i<name.size();i++){
                cout<<name[i]<<'
    ';
            }
        }
        return 0;
    }

    //加了个检测,AC了,但总感觉这样很。。。不要Face。。

  • 相关阅读:
    文件上传的核心点 一(59)
    ajax1—php(27)
    php—Smarty-缓存2(26)
    php—Smarty-缓存1(25)
    java—实现一个监听器HttpServletRequest的创建销毁、在线人数 (56)
    Linux—virtualbox系统安装(1)
    php—Smarty-2
    java—不同的用户登录以后可以看到不同的菜单(后台可以实现对用户菜单的管理) 1 (55)
    java—数据存储过程 (54)
    java—ThreadLocal模式与OSIV模式(53)
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9789670.html
Copyright © 2020-2023  润新知