• PAT 1022 Digital Library[map使用]


    1022 Digital Library (30)(30 分)

    A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

    • Line #1: the 7-digit ID number;
    • Line #2: the book title -- a string of no more than 80 characters;
    • Line #3: the author -- a string of no more than 80 characters;
    • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
    • Line #5: the publisher -- a string of no more than 80 characters;
    • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

    It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

    After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

    • 1: a book title
    • 2: name of an author
    • 3: a key word
    • 4: name of a publisher
    • 5: a 4-digit number representing the year

    Output Specification:

    For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

    Sample Input:

    3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    3333333
    Another Testing Book
    Yue Chen
    test code sort keywords
    ZUCS Print2
    2012
    2222222
    The Testing Book
    CYLL
    keywords debug book
    ZUCS Print2
    2011
    6
    1: The Testing Book
    2: Yue Chen
    3: keywords
    4: ZUCS Print
    5: 2011
    3: blablabla
    

    Sample Output:

    1: The Testing Book
    1111111
    2222222
    2: Yue Chen
    1111111
    3333333
    3: keywords
    1111111
    2222222
    3333333
    4: ZUCS Print
    1111111
    5: 2011
    1111111
    2222222
    3: blablabla
    Not Found

     题目大意:输入一个整数n,接下来共有n本书输入,书包括几个属性;接下来再进行查询,输出对应的id.

    代码来自:https://www.liuchuo.net/archives/2295

    #include <iostream>
    #include <map>
    #include <set>
    using namespace std;
    map<string, set<int> > title, author, key, pub, year;
    void query(map<string, set<int> > &m, string &str) {//需要使用引用传参,不然就超时了。
        if(m.find(str) != m.end()) {//find寻找是否有这个关键字。
            for(auto it = m[str].begin(); it != m[str].end(); it++)
                printf("%07d\n", *it);//这里需要是07,因为
        } else
            cout << "Not Found\n";
    }
    int main() {
        int n, m, id, num;
        scanf("%d", &n);
        string ttitle, tauthor, tkey, tpub, tyear;
        for(int i = 0; i < n; i++) {
            scanf("%d\n", &id);
            getline(cin, ttitle);
            title[ttitle].insert(id);//title是互异的,插入对应set中的id。
            getline(cin, tauthor);//getline可以直接读入到string里啊。
            author[tauthor].insert(id);//这个author下有多少个
            while(cin >> tkey) {//解决有空格的问题。
                key[tkey].insert(id);//这个关键词下对应的id。
                char c = getchar();//正常会获取到空格。
                if(c == '\n') break;
            }
            getline(cin, tpub);
            pub[tpub].insert(id);
            getline(cin, tyear);
            year[tyear].insert(id);
        }
        scanf("%d", &m);
        for(int i = 0; i < m; i++) {
            scanf("%d: ", &num);//一行内还可以分开读入。
            string temp;
            getline(cin, temp);
            cout << num << ": " << temp << "\n";
            if(num == 1) query(title, temp);
            else if(num == 2) query(author, temp);
            else if(num == 3) query(key, temp);
            else if(num == 4) query(pub,temp);
            else if(num ==5) query(year, temp);
        }
        return 0;
    }

    //简直不要太厉害啊,我的思路是,建立5个map,不过每个map的关键字都是id,每个id都对应一些结构,然后查询的时候,遍历每个id,判断其下是否存在对应的查询条件,这样真的很慢啊;还有对与使用getline时遇到了问题。这个代码和我的思路正好相反,十分简洁。

    1.可以使用getline(cin,str);实现对string的输入;

    2.使用getchar()可以获取多余的空格或者换行符;

    3.传参时使用引用,可以减少调用时间;

    4.scanf读入时的特点,map.find()中查找关键字是否存在;

    5.对于输入的内容又输出,像代码中的for循环,直接操作之后输出,不用中间存储。

  • 相关阅读:
    报告分享|2022年汽车行业研究最新动态
    合阔智云核心生产系统切换到服务网格 ASM 的落地实践
    ATC'22顶会论文RunD:高密高并发的轻量级 Serverless 安全容器运行时 | 龙蜥技术
    万节点规模云服务的 SRE 能力建设
    只需 6 步,你就可以搭建一个云原生操作系统原型
    智能搜索引擎 | 驱动电商业务增长实践
    Dubbo Mesh:从服务框架到统一服务控制平台
    性能透明提升 50%!SMC + ERDMA 云上超大规模高性能网络协议栈
    通过Jenkins构建CI/CD实现全链路灰度
    ARMS 助力羽如贸易打造全链路可观测最佳实践
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9431664.html
Copyright © 2020-2023  润新知