• PAT 1021 Deepest Root[并查集、dfs][难]


    1021 Deepest Root (25)(25 分)

    A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

    Output Specification:

    For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

    Sample Input 1:

    5
    1 2
    1 3
    1 4
    2 5
    

    Sample Output 1:

    3
    4
    5
    

    Sample Input 2:

    5
    1 3
    1 4
    2 5
    3 4
    

    Sample Output 2:

    Error: 2 components

     题目大意:对于图如果其是联通无环的,那么就是树,找出最深的树的所有起点。

     //不知道怎么找到所有的,找到两个可还行。

    //使用并查集判断是否是树,然后呢?

    代码来自:https://www.liuchuo.net/archives/2348

    #include <iostream>
    #include <vector>
    #include <set>
    #include <algorithm>
    using namespace std;
    int n, maxheight = 0;
    vector<vector<int>> v;
    bool visit[10010];
    set<int> s;
    vector<int> temp;
    void dfs(int node, int height) {
        if(height > maxheight) {
            temp.clear();//只存放最深的。
            temp.push_back(node);
            maxheight = height;
        } else if(height == maxheight){
            temp.push_back(node);
        }
        visit[node] = true;//一般图访问点完了之后,都要标记的,防止其下一个点再返回去访问它。
        for(int i = 0; i < v[node].size(); i++) {
            if(visit[v[node][i]] == false)
                dfs(v[node][i], height + 1);
        }
    }
    int main() {
        scanf("%d", &n);
        v.resize(n + 1);
        int a, b, cnt = 0, s1 = 0;
        for(int i = 0; i < n - 1; i++) {
            scanf("%d%d", &a, &b);
            v[a].push_back(b);//使用二维向量来存储。
            v[b].push_back(a);
        }
        for(int i = 1; i <= n; i++) {
            if(visit[i] == false) {
                dfs(i, 1);
                if(i == 1) {//其实这里随便一个点均可。
                    if (temp.size() != 0) s1 = temp[0];
                    for(int j = 0; j < temp.size(); j++)
                        s.insert(temp[j]);//再使用集合存储,防止重复。
                }
                cnt++;
            }
        }
        if(cnt >= 2) {
            printf("Error: %d components", cnt);
        } else {
            temp.clear();
            maxheight = 0;
            fill(visit, visit + 10010, false);
            dfs(s1, 1);
            for(int i = 0; i < temp.size(); i++)
                s.insert(temp[i]);
            for(auto it = s.begin(); it != s.end(); it++)
                printf("%d\n", *it);
        }
        return 0;
    }

    //厉害,使用dfs,传递层数参数,并且有一个maxHeight来保存最大的,厉害。

  • 相关阅读:
    iOS:Core Data 中的简单ORM
    Win8:Snap 实现
    js: 删除node的所有child
    WinJS:Listview item 设置背景透明
    iOS: 消息通信中的Notification&KVO
    win8: 清除iframe的缓存
    What's New in iOS7,iOS7新特性介绍
    "Entity Framework数据插入性能追踪"读后总结
    夜,思考——我想要的到底是什么?
    【查询】—Entity Framework实例详解
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9431018.html
Copyright © 2020-2023  润新知