• HDU 6208 The Dominator of Strings(AC自动机)


    The Dominator of Strings

    Time Limit: 3000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
    Total Submission(s): 2830    Accepted Submission(s): 1010

    Problem Description
    Here you have a set of strings. A dominator is a string of the set dominating all strings else. The string S is dominated by T if S is a substring of T.
     
    Input
    The input contains several test cases and the first line provides the total number of cases.
    For each test case, the first line contains an integer N indicating the size of the set.
    Each of the following N lines describes a string of the set in lowercase.
    The total length of strings in each case has the limit of 100000.
    The limit is 30MB for the input file.
     
    Output
    For each test case, output a dominator if exist, or No if not.
     
    Sample Input
    3
    10
    you
    better
    worse
    richer
    poorer
    sickness
    health
    death
    faithfulness
    youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness
     
    5
    abc
    cde
    abcde
    abcde
    bcde
     
     
    3
    aaaaa
    aaaab
    aaaac
     
    Sample Output
    youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness
    abcde
    No
     

    题目链接:HDU 6208

    检查你用的是不是假模板的好题……,经此一题,许多人发现自己学的是假AC自动机

    代码:

    #include <stdio.h>
    #include <iostream>
    #include <algorithm>
    #include <cstdlib>
    #include <cstring>
    #include <bitset>
    #include <string>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <set>
    #include <map>
    using namespace std;
    #define INF 0x3f3f3f3f
    #define LC(x) (x<<1)
    #define RC(x) ((x<<1)+1)
    #define MID(x,y) ((x+y)>>1)
    #define fin(name) freopen(name,"r",stdin)
    #define fout(name) freopen(name,"w",stdout)
    #define CLR(arr,val) memset(arr,val,sizeof(arr))
    #define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
    typedef pair<int, int> pii;
    typedef long long LL;
    const double PI = acos(-1.0);
    const int N = 100010;
    struct Trie
    {
        int nxt[26];
        int cnt, fail;
        void init()
        {
            for (int i = 0; i < 26; ++i)
                nxt[i] = -1;
            cnt = fail = 0;
        }
    } L[N];
    char s[N];
    int st[N], Len[N];
    int tot;
    
    namespace AC
    {
        void init()
        {
            tot = 0;
            L[tot++].init();
        }
        void insert(char s[], int len)
        {
            int u = 0;
            for (int i = 0; i < len; ++i)
            {
                int v = s[i] - 'a';
                if (L[u].nxt[v] == -1)
                {
                    L[tot].init();
                    L[u].nxt[v] = tot++;
                }
                u = L[u].nxt[v];
            }
            ++L[u].cnt;
        }
        void build()
        {
            L[0].fail = 0;
            queue<int>Q;
            for (int i = 0; i < 26; ++i)
            {
                if (L[0].nxt[i] == -1)
                    L[0].nxt[i] = 0;
                else
                {
                    L[L[0].nxt[i]].fail = 0;
                    Q.push(L[0].nxt[i]);
                }
            }
            while (!Q.empty())
            {
                int u = Q.front();
                Q.pop();
                int uf = L[u].fail;
                for (int i = 0; i < 26; ++i)
                {
                    int v = L[u].nxt[i];
                    if (v == -1)
                        L[u].nxt[i] = L[uf].nxt[i];
                    else
                    {
                        L[v].fail = L[uf].nxt[i];
                        Q.push(v);
                    }
                }
            }
        }
        int query(char s[], int len)
        {
            int ret = 0;
            int u = 0;
            for (int i = 0; i < len; ++i)
            {
                int v = s[i] - 'a';
                u = L[u].nxt[v];
                while (u && L[u].nxt[v] == -1)
                    u = L[u].fail;
                int t = u;
                while (t && L[t].cnt != -1)
                {
                    ret += L[t].cnt;
                    L[t].cnt = -1;
                    t = L[t].fail;
                }
            }
            return ret;
        }
    }
    int main(void)
    {
        int T, n, i;
        scanf("%d", &T);
        while (T--)
        {
            AC::init();
            scanf("%d", &n);
            int sum = 0;
            int Maxlen = 0;
            int ID = 0;
            for (i = 0; i < n; ++i)
            {
                scanf("%s", s + sum);
                Len[i] = strlen(s + sum);
                AC::insert(s + sum, Len[i]);
                st[i] = sum;
                sum += Len[i];
                if (Len[i] > Maxlen)
                {
                    ID = i;
                    Maxlen = Len[i];
                }
            }
            AC::build();
            if (AC::query(s + st[ID], Len[ID]) == n)
            {
                int ed = st[ID] + Len[ID];
                for (i = st[ID]; i < ed; ++i)
                    printf("%c", s[i]);
                puts("");
            }
            else
                puts("No");
        }
        return 0;
    }
  • 相关阅读:
    sp_trace_setfilter sqlserver筛选跟踪或跟踪过滤
    sp_trace_setevent sqlserver跟踪事件及列
    通过导入虚拟电脑的方式还原centos
    sqlserver profiler 抓出来作业的代码 SQLAgent
    克隆server2008R2造成SID冲突
    sqlserver ssms ctrl+e快捷键问题
    Caffe源码解析1:Blob
    梯度下降、随机梯度下降和批量梯度下降
    Caffe CNN特征可视化
    Caffe 抽取CNN网络特征 Python
  • 原文地址:https://www.cnblogs.com/Blackops/p/7568582.html
Copyright © 2020-2023  润新知