• POJ——3070Fibonacci(矩阵快速幂)


    Fibonacci
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12329   Accepted: 8748

    Description

    In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

    0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

    An alternative formula for the Fibonacci sequence is

    .

    Given an integer n, your goal is to compute the last 4 digits of Fn.

    Input

    The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

    Output

    For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

    Sample Input

    0
    9
    999999999
    1000000000
    -1

    Sample Output

    0
    34
    626
    6875

    Hint

    As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

    .

    Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

    .

    看了很多关于矩阵快速幂的题解,感觉矩阵快速幂得到的是一个含有多个项的矩阵,而答案只是其中一项,而且之还需要特判指数。入门的矩阵快速幂题。感受一下再写其它的题目。拿这题为例。题目中给出的项从0开始,F0=0,F1=1,F2=1,F3=2。。就是一个斐波那契的数列。由于用矩阵,那至少要两项来组成矩阵,根据他的递推公式。可以得到

    [Fn,Fn-1]=[1*Fn-1+1*Fn-2,1*Fn-1+0*Fn-2]

    代码:

    #include<iostream>
    #include<algorithm>
    #include<cstdlib>
    #include<sstream>
    #include<cstring>
    #include<cstdio>
    #include<string>
    #include<deque>
    #include<stack>
    #include<cmath>
    #include<queue>
    #include<set>
    #include<map>
    using namespace std;
    typedef long long LL;
    #define INF 0x3f3f3f3f
    struct mat 
    {
    	LL m[2][2];
    	mat(){memset(m,0,sizeof(m));}
    };
    mat cheng(mat a,mat b)
    {
    	mat c;
    	for (int i=0 ;i<2; i++)
    	{
    		for (int j=0; j<2; j++)
    		{
    			for (int k=0; k<2; k++)
    			{
    				c.m[i][j]+=(a.m[i][k]*b.m[k][j])%10000;
    			}			
    		}
    	}
    	return c;
    }
    mat zxc(mat a,LL b)
    {
    	mat c;
    	c.m[0][0]=c.m[1][1]=1;
    	while (b!=0)
    	{
    		if(b&1)
    			c=cheng(c,a);
    		a=cheng(a,a);
    		b>>=1;
    	}
    	return c;
    }
    int main(void)
    {
    	LL n;
    	while (cin>>n&&n!=-1)
    	{
    		mat one;
    		if(n==0)
    		{
    			cout<<0<<endl;
    			continue;
    		}
    		else if(n==1)
    		{
    			cout<<1<<endl;
    			continue;
    		}
    		one.m[0][0]=one.m[1][0]=one.m[0][1]=1;
    		one=zxc(one,n-1);		
    		cout<<one.m[0][0]%10000<<endl;;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    Linux切换到su超级用户
    使用Qt ARM交叉编译提示“此qt版本具有一个未知的工具链”
    使用qwt提示error LNK2001 问题的解决方法
    JavaScript中的 in
    JavaScript中的this
    autocad2010指令全集
    Proj.NETProj.NET简介和示例(转载)
    高性能地图优化策略(转载)
    Emgu.CV,OpenCV for C#
    C# 转载网络爬虫
  • 原文地址:https://www.cnblogs.com/Blackops/p/5458939.html
Copyright © 2020-2023  润新知