• POJ 2352 stars(树状数组)


    Time Limit: 1000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

     Status

    Description

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

    Sample Input

    5
    1 1
    5 1
    7 1
    3 3
    5 5

    Sample Output

    1
    2
    1
    1
    0

    刚开始以为用二维的树状数组求矩阵内元素和..然而只会一维的...然后学长提示了这题的y是递增的,也就是说star i+1肯定在star i的右边,因此只需判断是否在下方即可。于是题目变成了一维树状数组的前n项和,若star出现过此X坐标点标记为1即可。然后题目还有个坑点就是X可能是0,然而树状数组要从1开始。因此将题目中每个点均后移1个单位,答案不影响

    代码:

    #include<iostream>
    #include<algorithm>
    #include<cstdlib>
    #include<sstream>
    #include<cstring>
    #include<cstdio>
    #include<string>
    #include<deque>
    #include<cmath>
    #include<queue>
    #include<set>
    #include<map>
    using namespace std;
    int tree[32010],n;
    int pos[15010];
    inline int lowbit(const int &k)
    {
    	return k&-k;
    }
    inline void add(int k,const int &val)
    {
    	while (k<=32009)
    	{
    		tree[k]+=val;
    		k+=lowbit(k);
    	}
    	return ;
    }
    inline int getsum(int k)
    {
    	int sum=0;
    	while (k)
    	{
    		sum+=tree[k];
    		k-=lowbit(k);
    	}
    	return sum;
    }
    int main (void)
    {
    	ios::sync_with_stdio(false);
    	int i,j,val,x,y;
    	while (cin>>n)
    	{		
    		memset(pos,0,sizeof(pos));
    		memset(tree,0,sizeof(tree));
    		for (i=1; i<=n; i++)
    		{
    			cin>>x>>y;
    			pos[getsum(++x)]++;
    			add(x,1);
    		}
    		for (i=0; i<n; i++)
    		{
    			cout<<pos[i]<<endl;
    		}
    	}
    	return 0;
    }
  • 相关阅读:
    数据库索引的作用和长处缺点
    iOS安全攻防(三):使用Reveal分析他人app
    SVN server的搭建
    腾讯2014年实习生招聘笔试面试经历
    JAVA数组的定义及用法
    一年成为Emacs高手(像神一样使用编辑器)
    给想上MIT的牛学生说几句
    四个好看的CSS样式表格
    dede 留言簿 多个
    破解中国电信华为无线猫路由(HG522-C)自己主动拨号+不限电脑数+iTV
  • 原文地址:https://www.cnblogs.com/Blackops/p/5399022.html
Copyright © 2020-2023  润新知