• HDU——1163Eddy's digital Roots(九余数定理+同余定理)


    Eddy's digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5745    Accepted Submission(s): 3160


    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.
     


     

    Input
    The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
     


     

    Output
    Output n^n's digital root on a separate line of the output.
     


     

    Sample Input
    2 4 0
     


     

    Sample Output
    4 4

    主要公式:n的数根(各位数字之和)等于n%9,因此每次都相乘并取模9。另外这题忘记加&&n让我WA了三次,无语

    另外:

     1.对于同一个除数,两个数之和(或差)与它们的余数之和(或差)同余。 

    2.对于同一个除数,两个数的乘积与它们余数的乘积同余。 

    3.对于同一个除数,如果有两个整数同余,那么它们的差就一  定能被这个除数整除。 

    4.对于同一个除数,如果两个数同余,那么他们的乘方仍然同余。

    代码:

    #include<iostream>
    #include<algorithm>
    using namespace std;
    int main(void)
    {
    	int n;
    	while (cin>>n&&n)
    	{
    		int sum=1;
    		for (int i=1; i<=n; i++)
    			sum=sum*n%9;
    		if(sum==0)
    			cout<<9<<endl;//while已经判断过0,因此这里的0实际是9.因此要输出9 
    		else		
    			cout<<sum<<endl; 
    	}
    	return 0;
    }
  • 相关阅读:
    match、match_phrase、term示例
    AVL树及java实现
    eclipse集成lombok注解不起作用
    红黑树原理详解
    为什么HashMap中链表长度超过8会转换成红黑树
    用deepin堆砌工作环境
    为什么黑客都不用鼠标?你听说过Linux吗?
    为什么二流程序员都喜欢黑php?
    看Linux 之父是如何定义 Linux?
    Linux 系统故障排查和修复技巧
  • 原文地址:https://www.cnblogs.com/Blackops/p/5356441.html
Copyright © 2020-2023  润新知