• PAT1054-----对于不符合要求的数值进行选择


    本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

    输入格式:

    输入第一行给出正整数 N(≤)。随后一行给出 N 个实数,数字间以一个空格分隔。

    输出格式:

    对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

    输入样例 1:

    7
    5 -3.2 aaa 9999 2.3.4 7.123 2.35
    

    输出样例 1:

    ERROR: aaa is not a legal number
    ERROR: 9999 is not a legal number
    ERROR: 2.3.4 is not a legal number
    ERROR: 7.123 is not a legal number
    The average of 3 numbers is 1.38
    

    输入样例 2:

    2
    aaa -9999
    

    输出样例 2:

    ERROR: aaa is not a legal number
    ERROR: -9999 is not a legal number
    The average of 0 numbers is Undefined
    #include <stdio.h>
    #include<string.h>
    #include<iostream>
    #include <math.h>
    #include<ctype.h> 
    #include <malloc.h>
    #include <iomanip>
    #include <stdlib.h>
    using namespace std;
    int youxiao(char s[])
    {
        int n1=0,n2=0,i=0,dot=0;
        if(s[i]=='-')
        {
            i=1;
        }
        for(;s[i]!='';i++)
        {
            if((s[i] < 48 || 57 < s[i]) && s[i] != '.') return 0;
            if(dot==1&&s[i]=='.') return 0;
            if(dot==1) n2++;             //这一步不可以与下一步颠倒位置,否则多计算一个n2     
            if(s[i]=='.') dot=1;
            if(dot==0) n1++;
            
        }
        if (n2 > 2) return 0; // 小数部分多于两位不合法
        if (atof(s) < -1000.0 || atof(s) > 1000.0) return 0; // atof将字符串转换为浮点数,并判断范围是否合法
    
        return 1;
    }
    int main()
    {
        int n,cnt=0;
        double sum=0.0,v;
        char tmp[101]={0};
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>tmp;
            if(youxiao(tmp))
            {
                sum+=atof(tmp);
                cnt++;
            }else
            {
                cout<<"ERROR: "<<tmp<<" is not a legal number"<<endl;
            }
        }
        v=sum/cnt;
        cout<<"The average of ";
        if(cnt==0)
        {
            cout<<"0 numbers is Undefined";
        }
        if(cnt==1)
        {
            cout<<"1 number is ";
            printf("%.2f",v); 
        }
        if(cnt>=2)
        {
            printf("%d numbers is %.2f",cnt,v);
        }
        return 0;
    }

    https://blog.csdn.net/plank_root/article/details/51714578

  • 相关阅读:
    视频播放
    调用原生硬件 Api 实现照相机 拍照和相册选择 以及拍照上传
    获取设备信息 以及 获取地 理位置
    flutter_html 和 WebView 解析html 和 build.gradle源码
    flutter Dio()网络请求
    AlertDialog 、SimpleDialog、 showModalBottomSheet、showToast 自定义 Dialog
    前端小白页面开发注意事项及小工具(htmlcssjs)
    box-shadow 画叮当猫
    什么是冒泡排序?
    console.log
  • 原文地址:https://www.cnblogs.com/BananaMan/p/11324476.html
Copyright © 2020-2023  润新知