• ACM题目————The Blocks Problem


    代码参考:http://www.hankcs.com/program/uva-q101-the-blocks-problem.html

    Description

    Background 

    Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

    In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

    The Problem 

    The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all $0 leq i < n-1$ as shown in the diagram below:

     
    egin{figure}
centering
setlength{unitlength}{0.0125in} %
egin{picture}
(2...
...raisebox{0pt}[0pt][0pt]{$ullet
ullet ullet$ }}}
end{picture}
end{figure}
    Figure: Initial Blocks World

     

    The valid commands for the robot arm that manipulates blocks are:

    • move a onto b

      where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

    • move a over b

      where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

    • pile a onto b

      where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

    • pile a over b

      where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.

    • quit

      terminates manipulations in the block world.

    Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

    The Input 

    The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.

    The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

    You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

    The Output 

    The output should consist of the final state of the blocks world. Each original block position numbered i ( $0 leq i < n$ where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

    There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

    Sample Input 

    10
    move 9 onto 1
    move 8 over 1
    move 7 over 1
    move 6 over 1
    pile 8 over 6
    pile 8 over 5
    move 2 over 1
    move 4 over 9
    quit
    

    Sample Output 

     0: 0
     1: 1 9 2 4
     2:
     3: 3
     4:
     5: 5 8 7 6
     6:
     7:
     8:
     9:
    

     模拟题,直接按题目走就好,但是,为什么不能用队列?

    //Asimple hash
    //#include <bits/stdc++.h>
    #include <stdio.h>
    #include <iostream>
    #include <algorithm>
    #include <iterator>
    #include <deque>
    #include <string>
    #include <string.h>
    #include <vector>
    #include <stack>
    #include <ctype.h>
    #include <queue>
    #include <math.h>
    #include <stdlib.h>
    #include <map>
    #include <set>
    #include <time.h>
    #include <bitset>
    #include <list>
    
    using namespace std;
    typedef long long ll ;
    typedef list<int>::iterator iter;
    const int maxn = 25;
    int n;
    list<int> L[maxn];//为什么不能直接用队列?
    
    void Print_L()
    {
        for(int i=0; i<n; i++)
        {
            cout << i << ":" ;
            for( iter it = L[i].begin(); it !=L[i].end(); it++)
                cout << " " << *it ;
            cout << endl ;
        }
    }
    
    iter search(int &i, const int& x)
    {
        for( i=0; i<n; i++)
        {
            iter it = find(L[i].begin(),L[i].end(), x);//找x
            if(it != L[i].end() ) return it ;
        }
    }
    
    void restore(const int& i, iter it)
    {
        ++ it;
        while( it != L[i].end() )
        {
            L[*it].push_back(*it);
            it = L[i].erase(it);
        }
    }
    
    
    int main()
    {
        cin >> n ;
        for(int i=0; i<n; i++)
        {
            L[i].clear();
            L[i].push_back(i);
        }
        string str;
        while( cin >> str )
        {
            if( str == "quit" )
            {
                Print_L();
                break ;
            }
            else
            {
                string s;
                int a, b;
                cin >> a >> s >> b ;
                if( a == b ) continue ;//相等不行动
                int la, lb;
                iter pa = search(la, a);//找首次出现a的位置
                iter pb = search(lb,b);
                if( la == lb ) continue ;//两数是同一个手臂上的,不处理
                if( str == "move" )
                {
                    if( s == "onto" )
                    {
                        restore(la,pa);
                        restore(lb,pb);
                        L[lb].push_back(*pa);
                        L[la].erase(pa);
                    }
                    else if( s == "over")
                    {
                        restore(la,pa);
                        L[lb].push_back(*pa);
                        L[la].erase(pa);
                    }
                }
                else if( str == "pile" )
                {
                    if( s == "onto" )
                    {
                        restore(lb,pb);
                        while( pa!=L[la].end())
                        {
                            L[lb].push_back(*pa);
                            pa = L[la].erase(pa);
                        }
                    }
                    else if( s == "over" )
                    {
                        while( pa != L[la].end())
                        {
                            L[lb].push_back(*pa);
                            pa = L[la].erase(pa);
                        }
                    }
                }
            }
        }
    
        return 0;
    }
    
    低调做人,高调做事。
  • 相关阅读:
    什么是MongoDb
    Python之人工智能:PyAudio 实现录音 自动化交互实现问答
    Python人工智能之初识接口
    cordova(安卓)(腾讯信鸽注册绑定与反绑定) 插件开发
    sencha touch 在安卓中横屏、竖屏切换 应用崩溃问题
    Sencha Touch 实战开发培训 电子书 基础篇
    wps 批量调整图片大小 宏
    使用 crosswalk-cordova 打包sencha touch 项目,再也不用担心安卓兼容问题!
    Sencha Cmd 5.0.1.231 是坑爹货
    sencha touch api 使用指南
  • 原文地址:https://www.cnblogs.com/Asimple/p/5517846.html
Copyright © 2020-2023  润新知