• ACM题目————Anagram


    Description

    You are to write a program that has to generate all possible words from a given set of letters.
    Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".
    In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

    Input

    The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

    Output

    For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

    Sample Input

    3
    aAb
    abc
    acba
    

    Sample Output

    Aab
    Aba
    aAb
    abA
    bAa
    baA
    abc
    acb
    bac
    bca
    cab
    cba
    aabc
    aacb
    abac
    abca
    acab
    acba
    baac
    baca
    bcaa
    caab
    caba
    cbaa
    

    Hint

    An upper case letter goes before the corresponding lower case letter.
    So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.
     
    STL的全排列问题,写好排序方案,直接调用 next_permutation()函数便可!
    #include <cstdio>
    #include <string>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    int n;
    char str[15];
    
    bool cmp(char a,char b)
    {
        if(tolower(a)==tolower(b))
            return a<b;
        else
            return tolower(a)<tolower(b);
    }
    
    int main()
    {
        scanf("%d",&T);
        while( T-- )
        {
            scanf("%s",str);
            sort(str,str+strlen(str),cmp);//自定义排序
            do
            {
                cout << str << endl ;
            }while(next_permutation(str,str+strlen(str),cmp));
        }
    
        return 0;
    }
    
     
    低调做人,高调做事。
  • 相关阅读:
    Instruments之Core Animation学习
    Instruments之Allocations
    Instruments之Activity Monitor使用入门
    Instruments之相关介绍(一)
    快速理解Java中的五种单例模式
    iOS单例详解
    eclipse设置代码自动提示
    iOS-静态库,动态库,framework,bundle浅析(四)
    8.0docker的客户端和守护进程
    1.0 docker介绍
  • 原文地址:https://www.cnblogs.com/Asimple/p/5516856.html
Copyright © 2020-2023  润新知