• 刷题总结——Human Gene Functions(hdu1080)


    题目:

    Problem Description

    It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

    A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

    A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

    Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 

    Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix. 

    For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned: 

    AGTGAT-G 
    -GT--TAG 

    In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

    * denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

    Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

    AGTGATG 
    -GTTA-G 

    This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

    Input

    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100. 

    Output

    The output should print the similarity of each test case, one per line. 

    Sample Input

    2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA

    Sample Output

    14 21

    题解:

      类似于求lcs一样地dp,用f[i][j]表示第一个字符串匹配了前i个,第二个字符串匹配了前j个时的最高分数····推出dp方程:

       f[i][j]=max(f[i-1][j-1]+table[a[i]][b[j]],max(f[i-1][j]+table[a[i]][4],f[i][j-1]+table[4][b[j]]));

      其中table是题目中的分数表格····

    代码:

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cmath>
    #include<ctime>
    #include<cctype>
    #include<cstring>
    #include<string>
    #include<algorithm>
    using namespace std;
    const int N=105;
    const int table[5][5]={5,-1,-2,-1,-3,
                           -1,5,-3,-2,-4,         
                           -2,-3,5,-2,-2,
                           -1,-2,-2,5,-1,
                           -3,-4,-2,-1,0};
    int n,m,T,a[N],b[N],f[N][N];
    char s[N],t[N];
    int trans(char s[],int i)
    {
      if(s[i]=='A')  return 0;
      else if(s[i]=='C')  return 1;
      else if(s[i]=='G')  return 2;
      else if(s[i]=='T')  return 3;
    }
    int main()
    {
      //freopen("a.in","r",stdin);
      scanf("%d",&T);
      while(T--)
      {
        scanf("%d%s%d%s",&n,s+1,&m,t+1);memset(f,0,sizeof(f));
        for(int i=1;i<=n;i++)  a[i]=trans(s,i);
        for(int i=1;i<=m;i++)  b[i]=trans(t,i);
        for(int i=1;i<=n;i++)  f[i][0]=f[i-1][0]+table[a[i]][4];
        for(int i=1;i<=m;i++)  f[0][i]=f[0][i-1]+table[4][b[i]];
        for(int i=1;i<=n;i++)
          for(int j=1;j<=m;j++)
            f[i][j]=max(f[i-1][j-1]+table[a[i]][b[j]],max(f[i-1][j]+table[a[i]][4],f[i][j-1]+table[4][b[j]]));
        cout<<f[n][m]<<endl;
      }
      return 0;
    }

     

  • 相关阅读:
    C/C++中变量的作用域和存储类型简介
    Java与JavaScript的区别你明白吗?
    js-2018-11-09 关于Array中的srot()方法和compare()方法
    js-2018-11-01 关于break和continue语句
    0427表格学习
    0426基础标签学习
    css3部分整理
    img图片占不满整个div
    基于google protobuf 的 socket udp 通信
    微信小程序echarts学习记录
  • 原文地址:https://www.cnblogs.com/AseanA/p/7657730.html
Copyright © 2020-2023  润新知