• HDU Friend-Graph【暴力】【卡内存】【水题】


    Friend-Graph

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 464    Accepted Submission(s): 230


    Problem Description
    It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
    In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
    A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
     

    Input
    The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
    The first line od each case should contain one integers n, representing the number of people of the team.(n3000)

    Then there are n-1 rows. The ith row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
     

    Output
    Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
     

    Sample Input
    1 4 1 1 0 0 0 1
     

    Sample Output
    Great Team!
     

    Source

    题意:

    给你n个人之间的关系,如果超过三个人之间互相认识,或者超过三个人之间互相不认识,则输出“Bad Team!”,否则输出“Great Team!”

    思路:

    枚举三个人然后暴力求解,这个题会卡内存,注意存储关系用bool

    #include <bits/stdc++.h>
    #define INF 0x3f3f3f3f
    #define ms(x,y) memset(x,y,sizeof(x))
    using namespace std;
    
    typedef long long ll;
    
    const double pi = acos(-1.0);
    const int mod = 1e9 + 7;
    const int maxn = 3010;
    
    bool a[maxn][maxn];
    
    int main()
    {
    	//freopen("in.txt","r",stdin);
    	//freopen("out.txt","w",stdout);
    	int t;
    	scanf("%d", &t);
    	while (t--)
    	{
    		int n;
    		scanf("%d", &n);
    		for (int i = 1; i<n; i++)
    		{
    			for (int j = i + 1; j <= n; j++)
    			{
    				int p;
    				scanf("%d", &p);
    				a[i][j] = p;
    				a[j][i] = p;
    			}
    		}
    		bool ok = 1;
    		for (int i = 1; i <= n; i++)
    		{
    			for (int j = 1; j <= n; j++)
    			{
    				if (i == j) continue;
    				for (int k = 1; k <= n; k++)
    				{
    					if (i == k || k == j) continue;
    					if (a[i][j] && a[i][k] && a[j][k])
    						ok = 0;
    					if (!a[i][j] && !a[i][k] && !a[j][k])
    						ok = 0;
    					if (!ok) break;
    				}
    				if (!ok) break;
    			}
    			if (!ok) break;
    		}
    		if (ok) puts("Great Team!");
    		else puts("Bad Team!");
    	}
    	return 0;
    }


    Fighting~
  • 相关阅读:
    restful接口设计规范总结
    SSM框架中,配置数据库连接的问题
    Java通过mysql-connector-java-8.0.11连接MySQL Server 8.0遇到的几个问题
    浅谈Spring的PropertyPlaceholderConfigurer
    过滤器与拦截器的区别
    SpringMVC的拦截器(Interceptor)和过滤器(Filter)的区别与联系
    SpringMVC中使用Interceptor拦截器
    mybatis中模糊查询的使用以及一些细节问题的注意事项
    mybatis generator(MyBatis的逆向工程)
    mybatis-generator生成逆向工程两种方式
  • 原文地址:https://www.cnblogs.com/Archger/p/8451571.html
Copyright © 2020-2023  润新知