• 大数相乘


    Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

    Input

    Input starts with an integer T (≤ 525), denoting the number of test cases.

    Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

    Output

    For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

    Sample Input

    6

    101 101

    0 67

    -101 101

    7678123668327637674887634 101

    11010000000000000000 256

    -202202202202000202202202 -101

    Sample Output

    Case 1: divisible

    Case 2: divisible

    Case 3: divisible

    Case 4: not divisible

    Case 5: divisible

    Case 6: divisible

    就是判断前边的数字是否可以被后边的整除,,要按照字符串的格式处理

    #include<iostream>
    #include<string>
    using namespace std;
    int main(){
        int t,k=0;
        cin>>t;
        while(t--){
            k++;
            string a;
            int b;
            cin>>a>>b;
            long long ans=0,i=0;
            if(a[0]=='-') i++;
            for(;i<a.size();i++){
                ans=(ans*10+a[i]-'0')%b;
            }
            printf("Case %d: ",k);
            if(ans==0)puts("divisible");
            else puts("not divisible");
        }
        return 0;
    }
  • 相关阅读:
    java之类的封装
    java飞机大战之子弹的自动生成
    java之线程飞机大战制作
    java线程游戏之背景图片的移动
    mysql的安装以及简单的命令符
    java之控制多幅图片
    java之线程
    JAVA之数组队列
    java之链表
    python之数据库的操作(课前准备)
  • 原文地址:https://www.cnblogs.com/Accepting/p/11355292.html
Copyright © 2020-2023  润新知