• 【poj 1704】Georgia and Bob


    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 9776 Accepted: 3222
    Description

    Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, …, and place N chessmen on different grids, as shown in the following figure for example:

    Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

    Georgia always plays first since “Lady first”. Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

    Given the initial positions of the n chessmen, can you predict who will finally win the game?
    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 … Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
    Output

    For each test case, prints a single line, “Georgia will win”, if Georgia will win the game; “Bob will win”, if Bob will win the game; otherwise ‘Not sure’.
    Sample Input

    2
    3
    1 2 3
    8
    1 5 6 7 9 12 14 17
    Sample Output

    Bob will win
    Georgia will win

    【题目链接】:http://poj.org/problem?id=1704

    【题解】

    这题是阶梯博弈;
    可以这样;
    比如
    第2个样例
    8
    1 5 6 7 9 12 14 17
    则这样两两组合
    (1 5) (6 7) (9 12) (14 17)
    1和5之间有3个位置可供5往左移动
    6和7之间7是不能移动了的
    9和12之间有两个位置供12左移
    14和17之间有两个位置供17左移
    则对
    3 0 2 2做nim博弈;
    因为3^0^2^2不为0,所以先手赢;
    为什么呢?
    可以这样理解,
    先手减去3,0,2,2中的某一个数字;
    可以理解为把那一个组合右边的棋子左移了x格,x为这个数字的减少量
    比如吧最后一个2减去1;
    ->3 0 2 1
    就对应了棋盘上的棋子
    1 5 6 7 9 12 14 16
    如果后者不是移动组合中的右边那个棋子;
    而是左边的那个棋子;
    比如把14左移到了13;
    那么我们可以把16也左移1位到15
    那么棋子变成
    1 5 6 7 9 12 13 15
    对方面临的状态就还是不变依然为
    ->3 0 2 1
    如果对方不移动组合中右边的棋子,那么就不可能改变状态;(我们总能变回来);
    那么如果一开始的3,0,2,1做NIM游戏我们是赢的,那么我们就肯定能赢;
    相反,如果我们肯定会输,那么对手也能用这样的策略让我们保持输的状态;
    显然如果这4个数字全都变成0了;
    (这一瞬间,接下来要面临4个数字都是0且要操作的人肯定会输);
    (因为接下来只能操作每个组合中的左边的棋子了,对方怎么操作,你只要跟
    把右边那个棋子始终紧挨着它,最后对方就没棋子可以走了!);
    知道这一点后;
    再对奇数个棋子的情况进行考虑
    比如
    3
    3 8 16
    则在3前面加个0
    0 3 6 16
    ->(0 3) (6 16)
    ->2 9
    对2和9做NIM博弈就好;
    这里的分析和上面是一样的;
    最终你都能“逼”对方对组合中的右边的棋子进行操作;
    (也即减少尼姆博奕中各个堆中某个堆的石子个数);
    数据没说从小到大排序:(

    【完整代码】

    //#include <bits/stdc++.h> poj不支持这个
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define LL long long
    #define rep1(i,a,b) for (int i = a;i <= b;i++)
    #define rep2(i,a,b) for (int i = a;i >= b;i--)
    #define mp make_pair
    #define pb push_back
    #define fi first
    #define se second
    #define rei(x) scanf("%d",&x)
    #define rel(x) scanf("%I64d",&x)
    
    typedef pair<int,int> pii;
    typedef pair<LL,LL> pll;
    
    const int MAXN = 1e3+10;
    const int dx[9] = {0,1,-1,0,0,-1,-1,1,1};
    const int dy[9] = {0,0,0,-1,1,-1,1,-1,1};
    
    int a[MAXN];
    
    int main()
    {
        //freopen("F:\rush.txt","r",stdin);
        int T;
        rei(T);
        while (T--)
        {
            int n,ju,temp=0;
            rei(n);
            ju = n&1;
            rep1(i,1,n)
                rei(a[i]);
            sort(a+1,a+1+n);
            rep1(i,1,n)
                if ((i&1)==ju)
                    temp ^= a[i]-a[i-1]-1;
            if (temp!=0)
                puts("Georgia will win");
            else
                puts("Bob will win");
        }
        return 0;
    }
  • 相关阅读:
    二叉排序树
    堆排序
    线索化二叉树
    vue 格式化代码
    线程的理解
    声明式的服务调用 Feign
    使用锁 的理解
    zookeeper 的理解
    AQS 源码解析
    HashMap 的理解与结构
  • 原文地址:https://www.cnblogs.com/AWCXV/p/7626725.html
Copyright © 2020-2023  润新知