• PAT 1081 检查密码


    本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

    输入格式:
    输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

    输出格式:
    对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

    如果密码合法,输出Your password is wan mei.;
    如果密码太短,不论合法与否,都输出Your password is tai duan le.;
    如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
    如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
    如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。

    输入样例:

    5
    123s
    zheshi.wodepw
    1234.5678
    WanMei23333
    pass*word.6
    

    输出样例:

    Your password is tai duan le.
    Your password needs shu zi.
    Your password needs zi mu.
    Your password is wan mei.
    Your password is tai luan le.
    
    #include<iostream>
    #include<string>
    using namespace std;
    void islegal(string password){
      bool number=false, letter=false;
      if(password.size()<6||password.size()>80){
        cout<<"Your password is tai duan le."<<endl;
        return ;
      }
      else{
        for(int i=0; i<password.size(); i++){
          if(isdigit(password[i]))
            number=true;
          else if(isalpha(password[i]))
            letter=true;
          else if(password[i]=='.')
            continue;
          else{
            cout<<"Your password is tai luan le."<<endl;
            return ;
          }
        }
        if(number&&letter)
          cout<<"Your password is wan mei."<<endl;
        else if(number)
          cout<<"Your password needs zi mu."<<endl;
        else if(letter)
          cout<<"Your password needs shu zi."<<endl;
      }
    }
    int main(){
      int n;
      string password;
      cin>>n;
      getchar();
      for(int i=0; i<n; i++){
        getline(cin, password);
        islegal(password);
      }
      return 0;
    }
    
  • 相关阅读:
    多重平行中介(Mplus)
    小米手机,发短信出现闪退
    宇宙是有边还是没边?
    如何查一篇文章的引用文章
    卡方检验
    函数的形参与实参(二维数组)
    输出矩阵四周的数字的平均数(C)
    关于amos 的自由度
    Sql server case when then
    Sql Server中两个表之间数据备份和导入
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9833434.html
Copyright © 2020-2023  润新知