• PAT 1136 A Delayed Palindrome


    Consider a positive integer N written in standard notation with k+1 digits a​i as ak ⋯a1a0​ with 0≤ai <10 for all i and a​k​​ >0. Then N is palindromic if and only if a​i =ak−i for all i. Zero is written 0 and is also palindromic by definition.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

    Given any positive integer, you are supposed to find its paired palindromic number.

    Input Specification:

    Each input file contains one test case which gives a positive integer no more than 1000 digits.

    Output Specification:

    For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

    A + B = C

    where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

    Sample Input 1:

    97152

    Sample Output 1:

    97152 + 25179 = 122331
    122331 + 133221 = 255552
    255552 is a palindromic number.

    Sample Input 2:

    196

    Sample Output 2:

    196 + 691 = 887
    887 + 788 = 1675
    1675 + 5761 = 7436
    7436 + 6347 = 13783
    13783 + 38731 = 52514
    52514 + 41525 = 94039
    94039 + 93049 = 187088
    187088 + 880781 = 1067869
    1067869 + 9687601 = 10755470
    10755470 + 07455701 = 18211171
    Not found in 10 iterations.

    #include<iostream> //水题
    #include<algorithm>
    using namespace std;
    string getreverse(string a){
    	string b;
    	b.resize(a.size());
    	copy(a.rbegin(), a.rend(), b.begin());
    	return b;
    }
    string add(string a, string b){
    	string s;
    	int t=0;
    	for(int i=a.size()-1; i>=0; i--){
    		int p=a[i]-'0', q=b[i]-'0';
    		s.insert(s.begin(), (p+q+t)%10+'0');
    		t=(p+q+t)/10;
    	}
    	if(t!=0)
    		s.insert(s.begin(), t+'0');
    	return s;
    }
    bool judge(string a){
    	int k=a.size()-1;
    	for(int i=0; i<=k/2; i++)
    		if(a[i]!=a[k-i])
    			return false;
    	return true;
    }
    int main(){
    	string  a;
    	cin>>a;
    	if(judge(a)){
        	cout<<a<<" is a palindromic number."<<endl;
        	return 0;
    	}	
        for(int i=0; i<10; i++){
        	string b=getreverse(a);
        	string t=add(a,b);
        	cout<<a<<" + "<<b<<" = "<<t<<endl;
        	if(judge(t)){
        		cout<<t<<" is a palindromic number."<<endl;
        		return 0;
    		}	
        	a=t;
    	}
    	cout<<"Not found in 10 iterations."<<endl;
    	return 0;
    } 
    
  • 相关阅读:
    [OpenCV] Ptr类模板
    [OpenCV]Mat类详解
    [C++] Vector用法
    [OpeCV] highgui头文件
    c++中的.hpp文件
    【2017】KK English
    CMake Tutorial & Example
    [g2o]C++图优化库
    Teradata基础教程中的数据库试验环境脚本
    Oracle中对象权限与系统权限revoke
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9506943.html
Copyright © 2020-2023  润新知