• PAT 1121 Damn Single


    "Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

    Input Specification:
    Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

    Output Specification:
    First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

    Sample Input:
    3
    11111 22222
    33333 44444
    55555 66666
    7
    55555 44444 10000 88888 22222 11111 23333

    Sample Output:
    5
    10000 23333 44444 55555 88888

    #include<iostream> //水题
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main(){
      vector<int> couples(100000, 0), visited(100000, 0), single, ans;
      int n;
      cin>>n;
      for(int i=0; i<n; i++){
        int p, q;
        cin>>p>>q;
        couples[p]=q; 
        couples[q]=p;
      }
      cin>>n;
      for(int i=0; i<n; i++){
        int t;
        cin>>t;
        visited[t]=1;
        single.push_back(t);
      }
      for(int i=0; i<n; i++)
        if(visited[couples[single[i]]]==0)
          ans.push_back(single[i]);
      sort(ans.begin(), ans.end());
      cout<<ans.size()<<endl;
      for(int i=0; i<ans.size(); i++)
        i==0?printf("%05d", ans[i]):printf(" %05d", ans[i]);
      return 0;
    }
    
  • 相关阅读:
    2015-04-10一些知识点
    2015-04-07一些知识点
    斐波那契数列算法
    进制转换算法
    Java中transient有何作用?
    RandomAccessFile的使用
    Java各种类型占用的字节数
    LineNumberReader类的使用
    PreparedStatement和Statement的区别
    ResultSet几种类型的区别
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9502083.html
Copyright © 2020-2023  润新知