• PAT 1098. Insertion or Heap Sort


    According to Wikipedia:

    Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. At each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

    Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

    Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:

    10
    3 1 2 8 7 5 9 4 6 0
    1 2 3 7 8 5 9 4 6 0

    Sample Output 1:

    Insertion Sort
    1 2 3 5 7 8 9 4 6 0

    Sample Input 2:

    10
    3 1 2 8 7 5 9 4 6 0
    6 4 5 1 0 3 2 7 8 9

    Sample Output 2:

    Heap Sort
    5 4 3 1 0 2 6 7 8 9

    #include<iostream>
    using namespace std;
    int main(){
        int N; cin>>N;
        int i,j,flag=1,tag=0;
        int num0[N],num1[N];
        for(i=0;i<N;i++)
            cin>>num0[i];
        for(i=0;i<N;i++)
            cin>>num1[i];
        for(i=0;i<N-1;i++)
            if(num1[i]>num1[i+1]) break;
        for(j=i+1;j<N;j++)
            if(num1[j]!=num0[j]) flag=0;
        if(flag==0){
            cout<<"Heap Sort"<<endl;
            for(j=1;j<N;j++)
                if(num1[(j-1)/2]<num1[j]) break;
            j=j-1;
            int temp=num1[j];
            num1[j]=num1[0];
            num1[0]=temp;
            j--;
            int parent,child;
            temp=num1[0];
            for(parent=0;2*parent+1<=j;parent=child){
                child=parent*2+1;
                if(child<j&&num1[child+1]>num1[child])    
                   child++;
                if(num1[child]>temp)                     
    			   num1[parent]=num1[child];
                else 
    			   break;
            }
            num1[parent]=temp;
        }
        else{
            cout<<"Insertion Sort"<<endl;
            int temp=num1[i+1];
            for(i=i+1;i>0;i--)
                if(num1[i-1]>temp) num1[i]=num1[i-1];
                else break;
            num1[i]=temp;
        }
        for(int k=0;k<N;k++)
            if(tag++==0) cout<<num1[k];
            else cout<<" "<<num1[k];
        return 0;
    }
    
  • 相关阅读:
    java源码ReentrantLock源码分析1
    java源码Semaphore源码分析
    java源码HashMap源码分析
    java源码LinkedHashMap类设计
    java源码HashMap类设计
    java源码ConcurrentHashMap分析1
    java源码CountDownLatch源码分析
    转linux误删文件恢复 简单
    「翻译」Redis协议 简单
    刘昕明:送给和我一样曾经浮躁过的PHP程序员 简单
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8430017.html
Copyright © 2020-2023  润新知