• PAT 1089. Insert or Merge


    Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

    Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

    Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:

    10
    3 1 2 8 7 5 9 4 6 0
    1 2 3 7 8 5 9 4 6 0

    Sample Output 1:

    Insertion Sort
    1 2 3 5 7 8 9 4 6 0

    Sample Input 2:

    10
    3 1 2 8 7 5 9 4 0 6
    1 3 2 8 5 7 4 9 0 6

    Sample Output 2:

    Merge Sort
    1 2 3 8 4 5 7 9 0 6

    #include<iostream>
    using namespace std;
    void Merge(int b[],int l,int r,int rend,int temp[]){
        int lend=r-1,t=l,n=rend-l+1;
        t=l;
        while(l<=lend&&r<=rend){
            if(b[l]<b[r]) temp[t++]=b[l++];
            else temp[t++]=b[r++];
        }
        while(l<=lend) {temp[t++]=b[l++];}
        while(r<=rend) temp[t++]=b[r++];
    }
    int main(){
        int N; cin>>N; 
        int a[N],b[N],i,flag=0;
        for(i=0;i<N;i++)
            cin>>a[i];
        for(i=0;i<N;i++)
            cin>>b[i];
        for(i=0;i<N;i++)
            if(b[i]>b[i+1]) break;
               i++;
        for(int j=i;j<N;j++)
            if(a[j]!=b[j]) flag=1;
            if(flag==0){
               cout<<"Insertion Sort"<<endl;
               int temp=b[i];
               for(;i>0;i--)
                   if(temp<b[i-1]) b[i]=b[i-1];
                    else break;
               b[i]=temp;
               for(int j=0;j<N-1;j++)
                   cout<<b[j]<<" ";
               cout<<b[N-1]<<endl;
            }
            else{
               cout<<"Merge Sort"<<endl;
               int len,tag=0;
               for(len=2;len<N;len*=2){
                   for(int j=0;j<N-len;j+=2*len)
                       if(b[j+len-1]>b[j+len]) tag=1;
                   if(tag==1) break;
                }
                int temp[N],j;
                for(j=0;j<=N-2*len;j+=2*len)
                    Merge(b,j,j+len,j+2*len-1,temp);
                if(j<N-len)
                   Merge(b,j,j+len,N-1,temp);
                else
                   for(;j<N;j++)
                       temp[j]=b[j];
                for(int k=0;k<N-1;k++)
                    cout<<temp[k]<<" ";
                cout<<temp[N-1]<<endl; 
            }
        return 0;
    } 
    
  • 相关阅读:
    关于JAVA的线程问题
    Java 对JTextField添加回车响应
    Failed to install *.apk on device 'emulator-5554': timeout .
    静态属性
    类与对象的实例属性

    面向对象2
    面向对象设计
    re模块,主要用来查询
    xml对标签操作,
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8413393.html
Copyright © 2020-2023  润新知