• PAT 1088. Rational Arithmetic


    For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

    Input Specification:

    Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

    Output Specification:

    For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

    Sample Input 1:

    2/3 -4/2

    Sample Output 1:

    2/3 + (-2) = (-1 1/3)
    2/3 - (-2) = 2 2/3
    2/3 * (-2) = (-1 1/3)
    2/3 / (-2) = (-1/3)

    Sample Input 2:

    5/3 0/6

    Sample Output 2:

    1 2/3 + 0 = 1 2/3
    1 2/3 - 0 = 1 2/3
    1 2/3 * 0 = 0
    1 2/3 / 0 = Inf

    #include<iostream>
    #include<math.h>
    using namespace std;
    long long int getgcd(long long int s,long long int m){
        int r;
        while(r=s%m){
            s=m;
            m=r;
        }
        return m; 
    }
    void print(long long int s,long long int m){
        int sign=1;
        if(m==0){
        cout<<"Inf";
        return; 
        }
        if(s<0){
          s=abs(s);
          sign*=-1;
        }
        if(m<0){
          m=abs(m);
          sign*=-1;
        }
        int gcd=getgcd(s,m);
        s/=gcd;
        m/=gcd;
        if(sign<0) cout<<"(-";
        if(m==1) cout<<s;
        else if(s>m) cout<<s/m<<" "<<s%m<<"/"<<m;
        else cout<<s<<"/"<<m;
        if(sign<0) cout<<")";
    }
    int main(){
        long long int s1,m1,s2,m2;
        char op[4]={'+','-','*','/'};
        scanf("%lld/%lld %lld/%lld",&s1,&m1,&s2,&m2);
        for(int i=0;i<4;i++){
            print(s1,m1);
            cout<<" "<<op[i]<<" ";
            print(s2,m2);
            cout<<" = ";
            switch(i){
                case 0:print(s1*m2+s2*m1,m1*m2); break;
                case 1:print(s1*m2-s2*m1,m1*m2); break;
                case 2:print(s1*s2,m1*m2); break;
                case 3:print(s1*m2,m1*s2); break;
            }
            cout<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    1405ST软件测试课的要求补充说明
    软测实验课安排和考试
    Asp.Net 4.0 FormAuthentication 原理
    微信支付-“申请退款”接口遇到curl出错,错误码:58
    前端资源构建-Grunt环境搭建
    微信服务号开发-获取用户位置信息
    微信支付开发-当前页面的URL未注册
    Using Redis to store php session
    nginx performance monitor
    thinkphp nginx php-fpm url rewrite 导致 404 错误
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8413370.html
Copyright © 2020-2023  润新知