• PAT 1070. Mooncake


    Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

    Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

    Sample Input:

    3 200
    180 150 100
    7.5 7.2 4.5

    Sample Output:

    9.45

    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<iomanip>
    using namespace std;
    struct mooncake{
            double storage;
            double profit;
            double profit_per;                                                      
    };
    bool comp(const mooncake& m1,const mooncake& m2){return m1.profit_per<m2.profit_per;}                
    int main(){
        double kinds,max_demand;
        double Profit=0;
        cin>>kinds>>max_demand;
        vector<mooncake> mooncakes;
        mooncakes.resize(kinds);
        for(int i=0;i<kinds;i++){cin>>mooncakes[i].storage;}
        for(int i=0;i<kinds;i++)
        {
        cin>>mooncakes[i].profit; 
        if(mooncakes[i].storage==0) //此处有坑,慎跳→_→
        mooncakes[i].profit_per=0;
        else
        mooncakes[i].profit_per=mooncakes[i].profit/mooncakes[i].storage;
        }
        sort(mooncakes.begin(),mooncakes.end(),comp);
        auto e=mooncakes.end()-1;
        while(e>=mooncakes.begin()){
            if(e->storage>=max_demand){Profit+=max_demand*e->profit_per; break;}
            else {Profit+=e->storage*e->profit_per; max_demand-=e->storage; e--;}
        }
        cout<<fixed<<setprecision(2)<<Profit<<endl;
        return 0;   
    } 
    
    
  • 相关阅读:
    网站描述description如何编写
    网站关键词布局设置,这样添加关键词排名很容易上来!
    长尾关键词挖掘工具和使用方法
    小站点如何做好长尾词库(600个长尾词排名的经验分享!)
    如何利用seo技术霸屏你的行业关键词排名
    利用seo技术排名热点新闻词引流(日IP增加2万+)
    yagmail模块的使用
    python--接口自动化
    Python--unittest参数化
    Python--日志模块
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8397413.html
Copyright © 2020-2023  润新知