• PAT 1048. Find Coins


    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

    Sample Input 1:

    8 15
    1 2 8 7 2 4 11 15
    

    Sample Output 1:

    4 11
    

    Sample Input 2:

    7 14
    1 8 7 2 4 11 15
    

    Sample Output 2:

    No Solution
    

    分析
    这题比较简单,应该属于散列吧

    #include<iostream>
    using namespace std;
    int face[501]={0};
    int main(){
    	int n,m,num;
    	cin>>n>>m;
    	for(int i=0;i<n;i++){
    		cin>>num;
    		face[num]++;
    	}
    	for(int i=1;i<=500;i++){
    		if(face[i]==0) continue;
    		face[i]--;
    		if(m-i>0&&m-i<=500&&face[m-i]>=1){
    		   cout<<i<<" "<<m-i<<endl;
    		   return 0;
    		}
    	}
    	cout<<"No Solution"<<endl;
    	return 0;
    }
    
  • 相关阅读:
    Django_jinja2
    css画太极
    python 自己实现map
    python 比赛 组合问题
    python 找素数
    如何快速掌握一门新技术/语言/框架
    jQuery常用事件-思维导图
    jQuery常用函数-思维导图
    jQuery选择器汇总-思维导图
    3.git版本控制-管理修改、撤销、删除
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8328332.html
Copyright © 2020-2023  润新知