• PAT 1024. Palindromic Number


    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number(回文数字). For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:
    67 3
    Sample Output 1:
    484
    2
    Sample Input 2:
    69 3
    Sample Output 2:
    1353
    3

    分析
    这题就是比较简单的回文数字判断加上大整数相加。

    #include<iostream>
    #include<algorithm>
    using namespace std;
    bool judge(string n){
    	for(int i=0;i<n.size()/2;i++)
    	    if(n[i]!=n[n.size()-1-i])
    	       return false;
    	return true;
    }
    string add(string m,string n){
    	int p=0,q;
    	string s;
    	for(int i=m.size()-1;i>=0;i--){
    		q=((m[i]-'0')+(n[i]-'0')+p)%10;
    		p=((m[i]-'0')+(n[i]-'0')+p)/10;
    		s.insert(s.begin(),1,'0'+q);
    	}
    	if(p) s.insert(s.begin(),1,'0'+p);
    	return s;
    }
    int main(){
    	string n;
    	int maxsteps,cnt=0;
    	cin>>n>>maxsteps;
    	while(cnt<maxsteps){	
    		if(judge(n))
    		   break;
    		string m=n;
    		reverse(m.begin(),m.end());
    		n=add(m,n);
    		cnt++;
    	}
    	cout<<n<<endl<<cnt;
    	return 0;
    }
    
  • 相关阅读:
    Caused by: java.io.IOException: 你的主机中的软件中止了一个已建立的连接。
    jauery加入项目中,但是在页面中显示没有找到这个文件--springMVC框架
    SpringMVC中Controller和RestController
    firefox与chrome中对select下拉框中的option支持问题
    Spring与jsp表达式的产生的问题
    javaScript基础练习题-下拉框制作(神奇的代码)
    javaScript基础练习题-下拉框制作(JQuery)
    云,git,blog,感想
    javaScript基础练习题-下拉框制作(CSS)
    javaScript基础练习题-下拉框制作
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8289078.html
Copyright © 2020-2023  润新知