• PAT 1004. Counting Leaves


    PAT 1004. Counting Leaves (30)

    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
    Input

    Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    Output

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

    Sample Input

    2 1
    01 1 02
    

    Sample Output

    0 1
    

    分析

    树的遍历

    代码如下

    #include<iostream>
    #include<vector>
    using namespace std;
    vector<int> result(100,0);
    vector<int> vi[101];
    int maxdepth=-1;
    void dfs(int parent,int depth){
    	if(vi[parent].size()==0){
    		result[depth]++;
    		maxdepth=depth>maxdepth?depth:maxdepth;
    		return;
    	}
    	for(int i=0;i<vi[parent].size();i++)
    	dfs(vi[parent][i],depth+1);
    }
    int main(){
      int n,m,parent,num,child;
      cin>>n>>m;
      for(int i=0;i<m;i++){
      	cin>>parent>>num;
      	for(int j=0;j<num;j++){
      		cin>>child;
      		vi[parent].push_back(child);
    	  }
      }
      dfs(1,0);
      for(int i=0;i<=maxdepth;i++)
      i>0?cout<<" "<<result[i]:cout<<result[i];
      return 0;	
    } 
    
  • 相关阅读:
    Sql Server textcopy 的使用
    看来,我还是不适合犯罪
    Oracle 游标范例
    嵌入式学习方法 关于ARM+linux(转)
    存储控制器与外设之间的关系 (SDRAM与BANK6连接概述)
    socket和多线程可移植性编程基础(转)
    Linux设备驱动开发环境的搭建(转)
    Android JNI知识简介
    Linux USB驱动框架分析
    LINUX系统中动态链接库的创建和使用
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8185431.html
Copyright © 2020-2023  润新知