• poj 3176 Cow Bowling


    Description

    The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

              7
    

    3 8

    8 1 0

    2 7 4 4

    4 5 2 6 5
    Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

    Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

    Input

    Line 1: A single integer, N 

    Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

    Output

    Line 1: The largest sum achievable using the traversal rules

    Sample Input

    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    Hint

    Explanation of the sample: 

              7
    
    *
    3 8
    *
    8 1 0
    *
    2 7 4 4
    *
    4 5 2 6 5
    The highest score is achievable by traversing the cows as shown above.

    Source

    基础动态规划,每个数可以加到他下方相邻的两个数上,如此每个数可以加上上方相邻的两个数,选择大的那个。最后选择最大的。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    #include <cstdlib>
    #include <algorithm>
    #define MAX 351
    #define inf 0x3f3f3f3f
    using namespace std;
    int n;
    int s[MAX][MAX];
    int main() {
        scanf("%d",&n);
        for(int i = 1;i <= n;i ++) {
            for(int j = 1;j <= i;j ++) {
                scanf("%d",&s[i][j]);
                s[i][j] += max(s[i - 1][j],s[i - 1][j - 1]);
            }
        }
        int ans = 0;
        for(int i = 1;i <= n;i ++) {
            ans = max(ans,s[n][i]);
        }
        printf("%d",ans);
    }
  • 相关阅读:
    怎么修改android飞行模式wifi
    斐讯n1盒子装远程迅雷
    Spring使用大全
    面向对象7大设计原则
    Mybatis之SqlNode解析
    【转载】MongoDB的C#驱动程序教程
    【转载】 mongodb C# 基本类库
    【转载】列举MongoDB C#驱动的几个Query方法
    【转载】MongoDB开发学习
    【转载】sql全国省市区数据库建表过程
  • 原文地址:https://www.cnblogs.com/8023spz/p/9522817.html
Copyright © 2020-2023  润新知