• poj 3050 Hopscotch


    Description

    The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

    They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

    With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

    Determine the count of the number of distinct integers that can be created in this manner.

    Input

    * Lines 1..5: The grid, five integers per line

    Output

    * Line 1: The number of distinct integers that can be constructed

    Sample Input

    1 1 1 1 1
    1 1 1 1 1
    1 1 1 1 1
    1 1 1 2 1
    1 1 1 1 1

    Sample Output

    15

    Hint

    OUTPUT DETAILS: 
    111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

    Source

    给出一个5*5的矩阵由数字组成,要求从一个数字开始,每次只能跳到邻接四个方位的数字上,可以跳到访问过的数字上,问这样连续的过程能组成多少个六位数(可以有前导零),直接dfs暴力,map标记。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <map>
    #include <cstdlib>
    #include <algorithm>
    #define MAX 10001
    #define inf 0x3f3f3f3f
    using namespace std;
    int mp[5][5],ans;
    map<int,int> p;
    int dir[4][2] = {0,1,1,0,0,-1,-1,0};
    void dfs(int x,int y,int d) {
        if(d >= 1000000) {
            d -= 1000000;
            if(!p[d]) {
                p[d] = 1;
                ans ++;
            }
            return;
        }
        for(int i = 0;i < 4;i ++) {
            int tx = x + dir[i][0];
            int ty = y + dir[i][1];
            if(tx < 0 || ty < 0 || tx > 4 || ty > 4)continue;
            dfs(tx,ty,d * 10 + mp[tx][ty]);
        }
    }
    int main() {
        for(int i = 0;i < 5;i ++) {
            for(int j = 0;j < 5;j ++) {
                scanf("%d",&mp[i][j]);
            }
        }
        for(int i = 0;i < 5;i ++) {
            for(int j = 0;j < 5;j ++) {
                dfs(i,j,10 + mp[i][j]);
            }
        }
        printf("%d",ans);
    }
  • 相关阅读:
    JVM垃圾回收机制
    浅谈类的几个基础构造函数
    三次登陆用户名 和密码
    干迷宫
    记录人生中的第一个bug
    js三元运算符? :
    Linux云服务器 磁盘分区失败
    python基础中遇到的问题(TypeError: unhashable type: 'list')
    python亲密数设计
    源码编译安装Protobuf
  • 原文地址:https://www.cnblogs.com/8023spz/p/9515640.html
Copyright © 2020-2023  润新知