• 1064. Complete Binary Search Tree (30)


    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:
    10
    1 2 3 4 5 6 7 8 9 0
    
    Sample Output:
    6 3 8 1 5 7 9 0 2 4
    

    没必要建树,直接用一个数组。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <map>
    using namespace std;
    int n,l[1001],tr[2010],c;
    void inorder(int k)
    {
        if(k > n)return;
        inorder(k * 2);
        tr[k] = l[c ++];
        inorder(k * 2 + 1);
    }
    void levelprint()
    {
        for(int i = 1;i <= n;i ++)
        {
            if(i == 1)printf("%d",tr[i]);
            else printf(" %d",tr[i]);
        }
    }
    int main()
    {
        scanf("%d",&n);
        for(int i = 0;i < n;i ++)
            scanf("%d",&l[i]);
        sort(l,l + n);
        inorder(1);
        levelprint();
    }
  • 相关阅读:
    设计模式-11-代理模式
    设计模式-10-装饰者
    设计模式-9-组合
    设计模式-8-适配器
    设计模式-7-原型模式
    设计模式-6-建造者
    设计模式-5-单例模式
    u-boot-1.1.6 设置新分区支持设备树
    u-boot-2014.10移植(8)重定位,支持NAND启动
    u-boot-2014.10移植(7)修改环境变量的存储位置
  • 原文地址:https://www.cnblogs.com/8023spz/p/8994576.html
Copyright © 2020-2023  润新知