• 1130. Infix Expression (25)


    Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

    data left_child right_child

    where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

    Figure 1
    Figure 2

    Output Specification:

    For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

    Sample Input 1:
    8
    * 8 7
    a -1 -1
    * 4 1
    + 2 5
    b -1 -1
    d -1 -1
    - -1 6
    c -1 -1
    
    Sample Output 1:
    (a+b)*(c*(-d))
    
    Sample Input 2:
    8
    2.35 -1 -1
    * 6 1
    - -1 4
    % 7 8
    + 2 3
    a -1 -1
    str -1 -1
    871 -1 -1
    
    Sample Output 2:
    (a*2.35)+(-(str%871))
    

    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <queue>
    using namespace std;
    struct tree
    {
        char str[11];
        int l,r;
    }s[21];
    int n,v[21],root;
    void infix(int k,int flag)
    {
        if(flag&&s[k].r != -1)putchar('(');
        if(s[k].l != -1)
        {
            infix(s[k].l,1);
        }
        if(s[k].str[0] == '-' && strlen(s[k].str) > 1)cout<<'('<<s[k].str<<')';
        else cout<<s[k].str;
        if(s[k].r != -1)
        {
            infix(s[k].r,1);
            if(flag)putchar(')');
        }
    }
    int main()
    {
        cin>>n;
        for(int i = 1;i <= n;i ++)
        {
            cin>>s[i].str>>s[i].l>>s[i].r;
            v[s[i].l] = 1;
            v[s[i].r] = 1;
        }
        for(int i = 1;i <= n;i ++)
        {
            if(!v[i])
            {
                root = i;
                break;
            }
        }
        if(root != -1)infix(root,0);
    }
  • 相关阅读:
    css---box-sizing
    float与inline-block的一些应用场景的区别
    一些html元素的最原始状态
    css之深入理解overflow
    css中的锚点
    新增UI样式
    zh-CN、zh-Hans区别
    SourceTree 3.3.6安装跳过注册安装
    Windows sever 由于管理员设置的策略,该磁盘处于脱机状态的解决方法。
    CentOS7.x安装VNC实录
  • 原文地址:https://www.cnblogs.com/8023spz/p/8516210.html
Copyright © 2020-2023  润新知