• 1106. Lowest Price in Supply Chain (25)


    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

    Input Specification:

    Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki ID[1] ID[2] ... ID[Ki]

    where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

    Sample Input:
    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0
    2 6 1
    1 8
    0
    0
    0
    
    Sample Output:
    1.8362 2
    

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cmath>
    #include <iomanip>
    
    using namespace std;
    int n,k,sub;
    double p,r,price[100005],m = 10000000000;
    int f[100005],ans[100005],c,m_c;
    void getprice(int k)
    {
        if(price[k] == 0)
        {
            getprice(f[k]);
            price[k] = price[f[k]] * r;
        }
    }
    int main()
    {
        scanf("%d%lf%lf",&n,&p,&r);
        price[0] = p;
        r = (100 + r) / 100;
        for(int i = 0;i < n;i ++)
        {
            scanf("%d",&k);
            if(k)
            {
                for(int j = 0;j < k;j ++)
                {
                    scanf("%d",&sub);
                    f[sub] = i;
                }
            }
            else ans[c ++] = i;
        }
        for(int i = 0;i < c;i ++)
        {
            getprice(ans[i]);
            if(m > price[ans[i]])m = price[ans[i]],m_c = 1;
            else if(m == price[ans[i]])m_c ++;
        }
        printf("%.4f %d",m,m_c);
    }
  • 相关阅读:
    UVA 1386
    疯狂Android演讲2 环境配置
    七内部排序算法汇总(插入排序、Shell排序、冒泡排序、请选择类别、、高速分拣合并排序、堆排序)
    【iOS发展-44】通过案例谈iOS重构:合并、格式化输出、宏观变量、使用数组来存储数据字典,而且使用plist最终的知识
    jQuery选择
    一个月操作总结
    C++易vector
    oracle rac 在完成安装错误。
    NginX issues HTTP 499 error after 60 seconds despite config. (PHP and AWS)
    解决Eclipse中文乱码的方法
  • 原文地址:https://www.cnblogs.com/8023spz/p/8419168.html
Copyright © 2020-2023  润新知