• 1043. Is It a Binary Search Tree (25)


    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

    Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:
    7
    8 6 5 7 10 8 11
    
    Sample Output 1:
    YES
    5 7 6 8 11 10 8
    
    Sample Input 2:
    7
    8 10 11 8 6 7 5
    
    Sample Output 2:
    YES
    11 8 10 7 5 6 8
    
    Sample Input 3:
    7
    8 6 8 5 10 9 11
    
    Sample Output 3:
    NO
    

    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #include <map>
    #include <cmath>
    using namespace std;
    struct tree
    {
        int data;
        tree *left,*right;
    }*head;
    int pre[1000],c,flag1,flag2;
    tree *creat()
    {
        tree *p = new tree();
        p -> left = p -> right = NULL;
        return p;
    }
    tree *build(int x,tree *head)
    {
        if(head == NULL)
        {
            head = creat();
            head -> data = x;
        }
        else if(head -> data <= x)head -> right = build(x,head -> right);
        else head -> left = build(x,head -> left);
        return head;
    }
    void preo(tree *head)
    {
        if(head == NULL || flag1)return;
        if(head -> data != pre[c ++])flag1 = 1;
        preo(head -> left);
        preo(head -> right);
    }
    void prer(tree *head)//镜像前序
    {
        if(head == NULL || flag2)return;
        if(head -> data != pre[c ++])flag2 = 1;
        prer(head -> right);
        prer(head -> left);
    }
    void posto(tree *head)
    {
        if(head == NULL)return;
        posto(head -> left);
        posto(head -> right);
        if(c)cout<<' '<<head -> data;
        else 
        {
            c = 1;
            cout<<head -> data;
        }
    }
    void postr(tree *head)//镜像后序
    {
        if(head == NULL)return;
        postr(head -> right);
        postr(head -> left);
        if(c)cout<<' '<<head -> data;
        else 
        {
            c = 1;
            cout<<head -> data;
        }
    }
    
    int main()
    {
        int n;
        cin>>n;
        head = NULL;
        for(int i = 0;i < n;i ++)
        {
            cin>>pre[i];
            head = build(pre[i],head);
        }
        preo(head);
        c = 0;
        prer(head);
        c = 0;
        if(flag1 && flag2)cout<<"NO"<<endl;
        else
        {
            cout<<"YES"<<endl;
            if(flag2)posto(head);
            else postr(head);
        }
    }
  • 相关阅读:
    讨论: 在WebControl中的Button,同时有onClientClick和onclick事件,验证控件实效
    在DropDownList中显示树形结构
    我的软件开场白+简单的通讯录
    DataList中动态添加控件遇到的问题
    伤心啊!不知道怎么感冒了
    存储过程实现无限级分类(2)
    上传文件类
    一个用泛型,和Sql语句分页的源代码
    在GridView中用Js实现全选
    [转]如何完美应对面试
  • 原文地址:https://www.cnblogs.com/8023spz/p/8039507.html
Copyright © 2020-2023  润新知