• 1033. To Fill or Not to Fill (25)


    With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

    Sample Input 1:
    50 1300 12 8
    6.00 1250
    7.00 600
    7.00 150
    7.10 0
    7.20 200
    7.50 400
    7.30 1000
    6.85 300
    
    Sample Output 1:
    749.17
    
    Sample Input 2:
    50 1300 12 2
    7.10 0
    7.00 600
    
    Sample Output 2:
    The maximum travel distance = 1200.00
    

    先按照距离排一下序。然后不断更新最短价格,每次都把油加满,如果遇到价格低的加油站,就在保证能到达当前点的前提下,多余的油清除,价格也相应改变,然后按照当前价格把油加满,如果遇到的价格不低,但是剩下的油不足以到大下一站,也把油加满,更新最小价格。
    代码:
    #include <cstdio>
    #include <iostream>
    #include <algorithm>
    using namespace std;
    #define Max 505
    double Cmax,D,Dave;
    int N,flag = 1;
    double capcity = 0,price = 0,dis = 0;
    struct tank
    {
      double distance,price;
    }s[Max];
    bool cmp(tank a,tank b)
    {
      return a.distance < b.distance;
    }
    int main()
    {
      cin>>Cmax>>D>>Dave>>N;
      for(int i = 0;i < N;i ++)
      {
        cin>>s[i].price>>s[i].distance;
      }
      s[N].distance = D;
      sort(s,s+N+1,cmp);
      double minp;///当前最小价格
    
      int i;
      for(i = 0;i < N + 1;i ++)
      {
          if(capcity*Dave - (s[i].distance - s[i - 1].distance)  < 0)
            {
                dis = s[i - 1].distance + capcity * Dave;
                flag = 0;
                break;
            }
    
            capcity -= (s[i].distance - s[i - 1].distance) / Dave;
            if(s[i].distance == D)break;
          if(minp > s[i].price)
            {
                price -= capcity * minp;
                minp = s[i].price;
                price += minp * Cmax;
                capcity = Cmax;
            }
            else if(s[i + 1].distance - s[i].distance > capcity * Dave)
            {
                minp = s[i].price;
                price += (Cmax - capcity) * minp;
                capcity = Cmax;
            }
      }
        if(!flag&&dis < D)printf("The maximum travel distance = %.2f",dis);
        else printf("%.2f",price - capcity * minp);
      return 0;
    }
  • 相关阅读:
    别再重复造轮子了,利用list创建任意数据类型的链表
    可配置内存池实现
    简单内存池实现
    基于本博客版本中的循环缓冲的测试(Linux环境)
    循环缓冲实现(ring buffer/circular buffer)
    recvfrom超时设置
    Linux系统如何做性能测试?
    深入理解虚拟内存机制
    Linux 内核的测试和调试
    python学习之路 实现简单的计算机功能。
  • 原文地址:https://www.cnblogs.com/8023spz/p/8022649.html
Copyright © 2020-2023  润新知